• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Champ Profession

Membre
Le champ profession ne s'affiche plus sur mon modèle.
Les professions sont pourtant bien enregistrées
Quelqu'un à l'explication?
Merci
 
Moderateur
Quel est votre modèle d'arbre ? Un modèle standard ? Si c'est un modèle "perso" il faut nous le donner (après l'avoir zippé).
 
Membre
En fait le champ profession est bien renseigné ( on le voit dans Fiche détaillée ) mais quelque-soit l'arbre, il ne s'affiche pas.
Merci de votre aide
 
Moderateur
Vérifiez que dans "Préférences/Préférences pour cette généalogie" vou savez bien Champ profession==Professions

prof.jpg
 
Moderateur
Pouvez-vous nous montrer ce que vous voyez dans la fiche simple (en sélectionnant une rubrique Profession ?
Voyez-vous aussi les Professions dans la Fiche simple ?
Vérifiez que dans "Préférences/Structure du fichier" il n'y a bien qu'une seule rubrique Profession.
Avec la généalogie de démonstration et le modèle d'arbre "mode1-2018.grf", voyez-vous les professions dans l'arbre ?
Est-ce bien G2020 que vous avez ?
 
Membre
Réponses
Voyez-vous aussi les Professions dans la Fiche simple ? NON
Vérifiez que dans "Préférences/Structure du fichier" il n'y a bien qu'une seule rubrique Profession.OUI
Avec la généalogie de démonstration et le modèle d'arbre "mode1-2018.grf", voyez-vous les professions dans l'arbre ? OUI
Est-ce bien G2020 que vous avez ? OUI

J'en perd mon latin :)
 
Membre
en fait quand je clique sur profession dans Fiche Détaillée, le détail sur la droite n’apparaît pas uniquement pour une généalogie, j'en ai deux autres qui fonctionnent parfaitement
J'ai joint une copie d'écran
 
Fichiers joints
  • Capture.JPG
    Capture.JPG
    70.3 KB · Affichages: 636
Membre
Voila ce que donne l'analyse de structure
Une alerte sur le champ profession
 
Fichiers joints
  • Capture2.JPG
    Capture2.JPG
    140.6 KB · Affichages: 634
Moderateur
Si vous avez ce message c'est que certaines Professions n'ont pas été transformées en "événement avec info" mais sont restées en mode texte.
- Vérifiez que vous n'avez pas une autre rubrique PROFESSION dans la liste de la structure du fichier.
- Vous pouvez aussi essayer "Utilitaires/Professions" ; acceptez la sauvegarde proposée.
 
Membre
En fait, c'est toutes les professions qui sont en mode texte
aucune de s'affiche
Et je n'ai pas deux champs profession dans structure et j'ai passé utilitaire/profession sans résultat
A vous lire
Merci pour votre aide
 
Moderateur
Je crois que j'ai compris ce qui vous arrive. Votre rubrique profession est dans un état intermédiaire entre le type "Texte" et le type "événement avec info". Votre structure du fichier indique "événement avec info" mais dans la base de données les info sont toujours en type Texte, alors à l'affichage, Généatique ne sait plus quoi faire et n'affiche rien. On passe dans cet état si on est en type "Texte", que l'on change en type "événement avec info" MAIS que l'on répond Non au message ".... confirmez-vous l'opération".
Il faut revenir au type "Texte" dans la structure du fichier, cliquer sur Valider et répondre Oui à la confirmation. Vous reviendrez en mode Texte, vous n'aurez plus de message d'erreur au contrôle de la structure du fichier et vos professions seront affichées dans les cases.
Après, si vous le souhaitez (c'est recommandé), vous pouvez revenir en mode "événement avec info", pour cela remettez en type "événement avec info" dans la structure du fichier et cliquez sur Valider, puis répondez Oui et tout redeviendra normal.
 
Membre
Bon j'ai résolu le problème en utilisant
Utilitaires/Tables/Autres tables
j'ai forcé en faisant une maj a réécrire les professions et geneatique l'a fait correctement
Donc affaire réglée même si je peine à comprendre l'origine du pb
Cordialement
 
Moderateur
Mais il a fallu que vous les récriviez profession par profession ; c'est laborieux si il y a beaucoup de professions différentes. En les réécrivant Généatique a dû les réécrire en tenant compte du type défini dans la structure du fichier, c'est à dire "événement avec info" mais il aurait été plus rapide de procéder comme je l'ai indiqué dans le message précédent.
Donc maintenant vous avez les profession en type "événement avec info". Faites toute de même tourner le contrôle de la structure du fichier pour vérifier qu'il ne voit plus de problème avec POFESSION.
 
Moderateur
Marvi974":ux7cu1l3 a dit:
....Donc affaire réglée même si je peine à comprendre l'origine du pb...
Curieux tout de même ! Je vous ai donné une explication détaillée et le moyen de régler le problème et on dirait que vous n'avez pas lu ce message.
J'ai signalé au cdip ce problème. Cet état intermédiaire de la rubrique Profession est tout à fait reproductible ainsi que ses conséquences.
 
Membre
Bonjour,
En fait je n'ai pas la main pour passer en TEXTE la rubrique PROFESSION ou peut être que je m'y prend mal
Il y'a toujours l'alerte sur le champ PROFESSION
ceux que j'ai modifié sont bons, puet etre en ai je oublié un?
A vous lire
Cordialement
 
Moderateur
Pour avoir la main, il faut que dans "Préférences/Préférences dans l'utilisation de Généatique/Avancé" vous cochiez "Mode expert".
Mais alors, si vous n'aviez pas la main, ce qui m'étonne c'est que vous ayez pu passer en Profession de type "événement avec info" (sans aller jusqu'au bout de la procédure). J'ai parfaitement reproduit les sympomes que vous décrivier, les messages d'erreur, le non affichage des professions dans les cases, .... mais il a fallu que je modifie le type de la rubrique Profession. Avant vos problèmes, vous souvenez-vous avoir fait une manip. sur Profession ?
Maintenant que vous avez retrouvé vos professions (d'après ce que vous avez dit) que donne le contrôle de la structure du fichier ; n'avez-vous plus de message signalant un problème sur la structure et de quel type est la rubrique Profession ?
 
Moderateur
Pour avoir la main, il faut que dans "Préférences/Préférences dans l'utilisation de Généatique/Avancé" vous cochiez "Mode expert".
Mais alors, si vous n'aviez pas la main, ce qui m'étonne c'est que vous ayez pu passer en Profession de type "événement avec info" (sans aller jusqu'au bout de la procédure). J'ai parfaitement reproduit les sympomes que vous décrivier, les messages d'erreur, le non affichage des professions dans les cases, .... mais il a fallu que je modifie le type de la rubrique Profession. Avant vos problèmes, vous souvenez-vous avoir fait une manip. sur Profession ?
Maintenant que vous avez retrouvé vos professions (d'après ce que vous avez dit) que donne le contrôle de la structure du fichier ; n'avez-vous plus de message signalant un problème sur la structure et de quel type est la rubrique Profession ?
 
Membre
Exact, je n'ai jamais été modifier la structure car ce mode expert je ne l'avais même pas remarqué et j’étais plutôt rassuré que je ne puisse pas modifier la structure.
Les manipulations que j'ai pu faire au préalable de l'incident profession sont : un import de fiches et Réparer/Restructurer si cela peut aider à déterminer l'origine du problème
Merci pour votre aide
Je vais faire une sauvegarde et faire la manipulation sur le champ Profession et ne plus avoir le message d'erreur en analyse de structure
Cordialement
 
Moderateur
C'est peut-être l'import de fiches qui a créé ce problème. Je vais essayer de reproduire le problème de cette façon.
En passant à G2020 aviez-vous accepté la modification de la rubrique Profession qui était proposée à l'ouverture d'une généalogie ?
 

CONCOURS

CONCOURS

Haut