• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Curseur de saisie qui ne clignote plus

Membre
Bonsoir à tous,
J'ai un petit problème qui, à la longue, commence à énerver:
Mon curseur de saisie de texte (la barre verticale qui clignote quand on fait de la saise) s'arrête de clignoter et devient fixe de façon définitive quand je vais dans une zone de saisie de notes (notes d'un individu, de couple ou d'évènement). Je dois, ensuite, à chaque fois aller dans le panneau de configuration, Propriétés du clavier pour réactiver le clignotement car le réglage de la fréquence de clignotement est passée à "Aucune". J'ai dû même, créer un raccourci du réglage du clavier pour y accéder plus facilement car je dois constamment réactiver ce clignotement.
Mon micro tourne sous Windows 7. Quelqu'un d'autre a t'il également ce problème ?
Qu'en pense le CDIP ?
Cordialement
Marcel
 
Membre expert
BétaTesteur Généatique
Bonjour,

Je constate la même chose sous XP. On se demande bien pourquoi Généatique manipule le clignotement du curseur. Au moins, le rétablissement du clignotement quand on quitte Généatique serait un minimum.

L'ouverture d'un document dans Word rétablit le clignotement du curseur sans passer par le panneau de configuration.
 
Membre expert
Modérateur
BétaTesteur Généatique
Sous Vista si j'ouvre Word (un vieux Word 2003 il est vrai) alors que Généatique est ouvert, non seulement le curseur de Word ne clignote plus mais après un "Entrée", je perds le curseur ; il faut recliquer dans la page pour le retrouver. Idem avec G2012.
 
Membre actif
Bili":1xss9gyc a dit:
J'ai XP et G2012, mais je ne constate pas ce phénomène. L'ampoule... :D

Sous Win7 et G2013, on a bien un arrêt du clignotement mais seulement après passage dans l'éditeur de notes (le curseur clignote au démarrage de G2013 dans les cases de saisie, mais s'arrête dès que l'on essaie de saisir une note)

La valeur du clignotement est mise à 0 dans le panneau de configuration/clavier, et il ne clignote plus dans aucune autre application !

J'ai tenté -avec succès- cette réparation proposée par Microsoft pour les services "terminal server"

Important : Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, veillez à sauvegarder et assurez-vous que vous savez le restaurer en cas de problème.

Pour activer le curseur clignotant, procédez comme suit :
Cliquez sur Démarrer, sur exécuter, tapez regedit dans la zone Ouvrir et puis cliquez sur OK.
Recherchez et puis cliquez sur la clé de Registre suivante :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
Dans le menu Edition , pointez sur Nouveau, puis cliquez sur Valeur de chaîne.
Tapez CursorBlinkEnable et appuyez sur ENTRÉE.
Avec le bouton droit de CursorBlinkEnable et puis cliquez sur Modifier.
Tapez 1 dans la zone valeur , puis cliquez sur OK.
Quittez l'éditeur du Registre.

Après cette manip : l'éditeur de notes de Geneatique coupe toujours le clignotement du curseur, mais quand je quitte G2013, il est rétabli à sa valeur d'origine et fonctionne à nouveau dans les autres applications.
C'est un progrès :wink:
Daniel
 
Membre actif
Je rencontre également le même problème sous W7.
Le fait de passer dans les notes de G2013,arrête le clignotement du curseur, etsi j'ouvre Word 2007, le curseur ne clignote plus. Et apparemment, il crée un autre problème (peut-être lié au clignotement du curseur) : lorsque dans le texte word il y a un lien hypertexte, il est quasiment impossible de le faire apparaître et de l'ouvrir, car il s'affiche très brièvement.
Amicalement
 
Membre
A Dan_69007
Bonsoir,
J'ai fait la manip sur le registre mais ça ne marche pas. Le curseur reste aussi immobile même en fermant Généatique.
Dans la partie que vous indiquez, à la création d'une nouvelle ligne, j'ai entre autres 2 choix en valeur de chaînes, "Valeur de chaîne multiples" ou "Valeurs de chaîne extensibles". J'ai créé une ligne avec le paramètre 1 en valeur de chaîne extensible".
Il s'agit vraisemblablement d'un bug de Généatique car pourquoi intervient-il sur ce paramètre du registre à la saisie des notes alors que dans la saisie des fiches il n'y a pas de problème.
Pas de réaction du CDIP pour l'instant. Je continue à intervenir ponctuellement à chaque saisie de note pour corriger le problème.
Cordialement.
Marcello
 
Membre actif
Marcello":1hbidfps a dit:
A Dan_69007
...création d'une nouvelle ligne, j'ai entre autres 2 choix en valeur de chaînes, "Valeur de chaîne multiples" ou "Valeurs de chaîne extensibles". J'ai créé une ligne avec le paramètre 1 en valeur de chaîne extensible"....
Marcello

ce n'est ni l'un ni l'autre : mais "valeur chaine" tout court : une fois créé, le type affiché sera REG_SZ et la valeur 1
supprimez la valeur multiple inutile.
Dans une autre version et pour le même problème, Microsoft indique que la valeur CursorBlinkEnable à créer est une valeur DWORD : faire l'essai avec ce type de valeur ?

Le problème dans WORD2007 signalé par AL1493 est répertorié dans le correctif suivant : http://support.microsoft.com/kb/962872 qui date de février 2009 : les mises à jour ultérieures ont intégré ce correctif, car on en est à la version SP3...

Ps : je viens de vérifier sur une autre machine W7, mais seulement équipée de Geneatique 2010... que le phénomène ne se produisait pas avec cette version :shock:
Ps2 : une dernière manip avec l'utilisation d'une valeur DWORD pour CursorBlinkEnable me semble fonctionner mieux que la précédente : si le curseur se fige pendant l'utilisation des notes de G2013, il redevient normal dès la fermeture et la valeur CursorBlinkRate n'est pas modifiée comme avant...
 
Membre
Bonjour,
Pas plus de résultat avec valeur DWord 32 bits ou même Qword 64 bits.
J'ai essayé avec "Valeur de chaîne à 1, rien non plus.
Tant pis je continue à aller à chaque fois dans le paramétrage du clavier en attendant que le CDIP se saisisse du problème.
Cdt
 
Membre actif
Bonjour,
J'ai résolu le problème de façon plus stable, en m'inspirant de la solution suggérée par Microsoft, qui était adaptée à un problème Terminal Server, et donc répondait incomplètement à notre souci.
Le comportement du curseur est géré pour chaque utilisateur dans la clé de registre :
HKEY_CURRENT_USER\Control Panel\Desktop
Il s'y trouve déjà une valeur Chaine CursorBlinkRate, qui est par défaut fixée à 530 (en milisec.). Elle est mise à (-1) quand le curseur ne clignote plus.
J'ajoute la valeur Chaine (REG_SZ) nommée CursorBlinkEnable, valeur 1 {le chiffre 1 et rien d'autre !}
résultat :
Quand j'utilise G2013 : le curseur clignote jusqu'à ce que j'ouvre une note (individuelle ou de couple) : il se fige dans geneatique, ainsi que dans Word ouvert en même temps. Il clignote toujours dans les autres applications.
Quand je ferme G2013 : le curseur clignote à nouveau dans Word. Il peut y avoir une certaine latence de quelques secondes, mais ça marche (Windows7 + Geneatique 2013)
(ps Marcello : supprimez du registre au fur et à mesure les valeurs "exotiques" que vous avez pu essayer)
ne désespérons pas :roll:
Daniel
 
Membre expert
BétaTesteur Généatique
Marcello":3rnitfnu a dit:
Bonsoir à tous,
Mon curseur de saisie de texte (la barre verticale qui clignote quand on fait de la saisie) s'arrête de clignoter et devient fixe de façon définitive quand je vais dans une zone de saisie de notes (notes d'un individu, de couple ou d'évènement). Je dois, ensuite, à chaque fois aller dans le panneau de configuration, Propriétés du clavier pour réactiver le clignotement car le réglage de la fréquence de clignotement est passée à "Aucune".
Qu'en pense le CDIP ?
Bonjour
La version 1.2.07 n'a toujours pas corrigé ce dysfonctionnement lié à la simple consultation d'une note d'un individu ou de couple. J'utilise windows 7 64 bits.
Ce dysfonctionnement est très embêtant car il interfère avec les autres applications de l'ordinateur (word, notepad, etc ...). La valeur du clignotement passe à 0 dans le panneau de configuration/clavier. Le rétablissement du clignotement serait bien apprécié. Je continue à intervenir pour corriger le problème, la solution proposée par dan_69007 "CursorBlinkEnable=1" ne fonctionne pas.
 
jlturbe":3lx91n3z a dit:
Marcello":3lx91n3z a dit:
Bonsoir à tous,
Mon curseur de saisie de texte (la barre verticale qui clignote quand on fait de la saisie) s'arrête de clignoter et devient fixe de façon définitive quand je vais dans une zone de saisie de notes (notes d'un individu, de couple ou d'évènement). Je dois, ensuite, à chaque fois aller dans le panneau de configuration, Propriétés du clavier pour réactiver le clignotement car le réglage de la fréquence de clignotement est passée à "Aucune".
Qu'en pense le CDIP ?
================================
Bonjour à tous.
La version 1.2.07 n'a toujours pas corrigé ce dysfonctionnement lié à la simple consultation d'une note d'un individu ou de couple. J'utilise windows 7 64 bits.
Ce dysfonctionnement est très embêtant car il interfère avec les autres applications de l'ordinateur (word, notepad, etc ...). La valeur du clignotement passe à 0 dans le panneau de configuration/clavier. Le rétablissement du clignotement serait bien apprécié. Je continue à intervenir pour corriger le problème, la solution proposée par dan_69007 "CursorBlinkEnable=1" ne fonctionne pas.
Bonsoir,
Effectivement, après mise à jour avec la dernière version de Généatique 2013, le problème subsiste. J'ai dû créer un raccourci de la configuration du clavier sur le bureau pour y accéder plus rapidement.
Je continue à penser que ce n'est pas une solution. Je réitère ma question: "Qu'en pense le CDIP ?" Combien de mises à jour faudra t'il pour ne plus être irrité par ce problème.
Marcello
 
Membre actif
marcello29":frdzhwfg a dit:
...
Je continue à penser que ce n'est pas une solution. Je réitère ma question: "Qu'en pense le CDIP ?" Combien de mises à jour faudra t'il pour ne plus être irrité par ce problème.
Marcello
C'est en effet pénible de ne pas sentir de bonne volonté sur ces petits "bugs" !
Je confirme que la solution modifiant la base de registre (dernier message en bas de la page précédente) fonctionne, au sens où elle évite de revenir chaque fois par le panneau de configuration...
Bien que les paramètres ne soient pas modifiés, le passage dans l'éditeur de notes de Généatique stoppe (provisoirement) le clignotement dans Word s'il est ouvert en même temps, ainsi que sur le présent forum :mrgreen:
Tout rentre dans l'ordre à la fermeture de geneatique -sans intervention spéciale-
 
Membre expert
BétaTesteur Généatique
Bili":2rw3udwi a dit:
J'ai XP et G2012, mais je ne constate pas ce phénomène.
L'ampoule du clignotant serait en cause ?? :D
Le problème existe également sous généatique 2012 sous XP
dan_69007":2rw3udwi a dit:
Je confirme que la solution modifiant la base de registre (dernier message en bas de la page précédente) fonctionne, au sens où elle évite de revenir chaque fois par le panneau de configuration...
Bien que les paramètres ne soient pas modifiés, le passage dans l'éditeur de notes de Généatique stoppe (provisoirement) le clignotement dans Word s'il est ouvert en même temps, ainsi que sur le présent forum
Le problème existe aussi également sous généatique 2013 1.2.0.7 sous Ubuntu avec Wine.
Petite différence , on a bien un arrêt du clignotement après passage dans l'éditeur de notes ou notes de couple (le curseur clignote au démarrage de G2013 dans les cases de saisie, mais s'arrête dès que l'on essaie de saisir une note ou qu'on la consulte), par contre si on revient dans les cases de saisie de la fiche simple, le curseur clignote à nouveau. Cela confirme bien que c'est le passage à l'onglet notes ou notes de couple qui a créé le dysfonctionnement.

dan_69007":2rw3udwi a dit:
Tout rentre dans l'ordre à la fermeture de geneatique -sans intervention spéciale-
Pour finir je confirme que la solution de dan_69007 modifiant la base de registre en ajoutant la valeur Chaine (REG_SZ) nommée CursorBlinkEnable, valeur 1 fonctionne mais seulement cela nécessite de fermer la session ou de redémarrer l'ordinateur. Le simple fait de fermer geneatique ne résout rien dans la session actuelle.
Quant à faire cela autant créer le raccourci clavier du panneau configuration proposé par Marcello (meilleure solution à l'heure actuelle)
Si le CDIP ou une autre personne a LA SOLUTION je suis interessé.
 
Membre actif
Bonjour,

Sous WIN 7 et G2013 1.0.2.7 j'observe les phénomènes suivants :
Avec G2013 ouvert si j'ouvre Word j'ai un clignotant normal qui disparaît à la première frappe. Il faut cliquer pour avoir un clignotant fixe disparaissant à la première frappe. Le curseur redevient normal avec un retour arrière mais disparaît à la première frappe.
En retournant dans G2013 et en ouvrant une note on a un curseur fixe mais qui ne disparaît pas à la frappe. En retournant dans Word sans fermer la note de G2013 le curseur est fixe et disparaît à la frappe. Il faut cliquer pour le faire réapparaître, toujours en fixe. Un retour AR est sans effet sur le clignotement.
J'ai lu des remèdes consistant à modifier la base de registre pour limiter ce phénomène ce que je trouve pour le moins incongru. En effet je me vois mal intervenir dans la base de registre pour limiter un défaut de G2013 au risque de planter mon ordinateur.
Il me semble qu'il appartient au CDIP de nous livrer un logiciel qui fonctionne directement sans interférer avec les autres applications en cours de service en appliquant le principe du multitâche.
Sans vouloir ouvrir de polémique je pense que le CDIP ferait bien de limiter ses développements qui tournent à l'abscons pour beaucoup d'entre nous pour enfin livrer une version qui fonctionne réellement et sans (ou presque sans. . . ) bugs. En caricaturant un peu on pourrait dire que la version actuelle ressemble par trop à un bricolage rafistolé de moultes façons dont les nouvelles anomalies générées par la correction des précédentes deviennent vraiment trop nombreuses et difficile à cerner.
 
Membre actif
Bonjour,

Après chargement de la version 1.0.2.8 (merci predigny !) on peut travailler dans WORD avec G2013 ouvert sans problème de curseur. Toutes fois le problème réapparaît pour la fin de la cession si on ouvre une note dans G2013 et demeure même après la fermeture de Généatique. Pour le faire cesser il faut fermer Généatique ET Word. Ce n'est qu'à la réouverture de Word que l'on constate que le phénomène a disparu.
 

gratuit

Haut