• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

G2021 - Intégration de photos

Bonsoir,
Je n'ai pas trouvé la solution au problème suivant :
J'ai voulu ajouter des photos associées à une personne selon la méthode suivante; Onglet Médias de l'écran de saisie --> Clic sur le bouton Photos et Portraits --> A partir de l'ordinateur --> Sélection du fichier image puis Enregistrer. Une fenêtre d'alerte s'ouvre alors : "Veuillez sélectionner l'évènement à associer", alors que l'image n'est à associer à aucun évènement.
Si on coche "Création d'un document" pas d'erreur mais la photo est mise dans l'onglet "EVENEMENTS Actes et Documents". Impossible donc de la rajouter dans l'onglet Photos et Portraits.
Qu'est-ce qui a été modifié dans cette version ?
Constatez-vous le même problème. J'ai la dernière version 2-5-1
Merci d'avance.
Marcello
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
En cliquant sur le bouton Photos et portraits, l'événement associé est déjà défini et vous ne devriez pas avoir cette demande de choisir un événement. Mais il se peut que cette événement (Image) ne soit pas bien défini ; Allez dans l'onglet "Essentiel", cliquez sur l'icône "Configuration de l'écran de saisie" et dans "Général" vérifiez que c'est bien l'événement Image qui est associé aux images ajoutées par l'onglet Médias.
 
Fichiers joints
  • even-image.jpg
    even-image.jpg
    14.2 KB · Affichages: 298
Bonjour,
Dans le paramétrage de l'écran de saisie, l'affichage par défaut était bien PHOTO.
Il fallait cliquer sur "Créer un évènement". Le fait de créer un évènement appelé PHOTOS est un peu déroutant. A chaque nouvelle version de Généatique, on retrouve des choses un peu bizarres qu'il faut sans doute considérer, bon gré mal gré comme des évolutions positives.
Merci en tout cas pour vos conseils.
Cordialement.
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
Ce n'est pas Photo mais Image que vous devriez avoir, et dans ce cas quand on ajoute une image par l'onglet Médias en cliquant sur le bouton Photo et portrait, l'événement a créer est déjà sélectionné à Images.
D'ailleurs le nom du fichier doit déjà être avec _Image ou _Img
 
Fichiers joints
  • even-image2.jpg
    even-image2.jpg
    37.2 KB · Affichages: 261
Dans le paramétrage de l'écran de saisie, dans la liste déroulante, j'ai PHOTOS mais j'ai compris en regardant la structure du fichier, créé il y a plusieurs années : en libellé j'ai IMAGE et en Libellé Ecran PHOTOS, donc c'est le Libellé écran qui s'affiche. Normal, donc dans la création d'un évènement c'est PHOTOS qui s'affiche. Mais ce qui est peut-être anormal c'est que G2021 ne sélectionne pas automatiquement l'évènement PHOTOS.
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
En effet, G2021 se réfère au libellé écran pour voir qu'il s'agit d'un "portrait". Normalement le libellé écran ne devrait pas intervenir dans la logique du logiciel ; c'est une anomalie. Avec G2020 ça existait peut-être déjà mais ce n'était pas visible.
Je crois qu'il vaut mieux que vous modifiez la rubrique IMAGE pour la rendre conforme à la rubrique standard (voir ci-dessous). Ajoutez aussi le "Légende". Le tag de niveau 2 n'est pas mis dans la rubrique standard mais il permet d'exporter le champ info (ou Légende) dans un gedcom.
 
Fichiers joints
  • Rub-image.jpg
    Rub-image.jpg
    38.4 KB · Affichages: 213
Dans "Structure du fichier", j'ai modifié le nom à l'écran en IMAGE. Eh bien, dans ce cas, ça ne marche pas non plus, rien n'est proposé en création d'évènement. L'application attend "Image" et non "IMAGE", et là, avec "Image" c'est OK (à noter qu'avec "image" sans initiale majuscule, ça ne marche pas non plus).
Si le CDIP pouvait corriger cette anomalie dans une prochaine mise à jour, sinon il ne sert à rien d'avoir une appellation à l'écran différente du nom de champ dans la base de données.
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
C'est bien "Image" que je proposais de mettre, mais c'est anormal qu'un libellé écran ait ce comportement. J'ai remonté cette anomalie au cdip.
 
Oui j'avais vu "Image" dans votre message mais j'ai voulu tester "IMAGE" pour voir.
Merci pour votre intervention.
Cordialement
Marcel
PS - J'espère qu'ils vont aussi corriger le problème de majuscule à chaque mot dans certains champs.
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
marcello29":2q9sha02 a dit:
...PS - J'espère qu'ils vont aussi corriger le problème de majuscule à chaque mot dans certains champs.
Oui oui, c'est en haut de la pile des problèmes à régler.
Pour l'affaire du libellé "Image" Il ne faudrait pas que cette correction (dans le fond pas indispensable si on utilise la rubrique standard) entraine une avalanche de fautes plus graves. Il n'y a que les programmeurs pour savoir si c'est une maladresse localisée ou si elle est à beaucoup d'endroits, auquel cas il vaudrait mieux laisser comme c'est.
 

gratuit

Haut