• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe
  • Découvrez la nouvelle section du forum : Réalisations dans Généatique. Montrez et partagez vos créations d'arbres dans Généatique !
    Et participez au concours !

Images dans Généatique 2024

Membre
Bonjour,

Je viens rajouter une question concernant les images / illustrations.
J'éprouve des difficulté depuis la version 2023 avec l'affichage des images.
Mais afin de repartir sur quelque chose de clair, j'ai pris le parti de recommencer à zéro, en sauvegardant ma généalogie sans les images, me permettant de nettoyer une base de données pleine de liens cassés.
Et d'autre part j'ai réinstallé Généatique après une suppression totale du logiciel et des dossiers liés.
Je pensais donc m'en sortir comme ça, mais que nenni! Rebelote, lorsque j'ajoute un fichier (une photo par exemple), l'ajout se fait bien, l'éditeur d'images s'ouvre, et je vois mon image, et lorsque je valide..... j'ai le lien vers la photo dans l'onglet "complet" de ma personne, mais l'image ne s'affiche pas.

Mes paramètres dans la gestion des médias sont:
- Gestion des médias par généatique
- Dans le sous dossier "images" de ma généalogie
- Médias non renommés

Par contre si je choisis l'option "les médias restent à l'emplacement choisi", l'affichage des images fonctionne! Le problème étant que les dossiers qui contiennent les images ne sont pas figés dans le marbre donc les liens peuvent être facilement obsolètes.

J'utilise geneatique sur Parallel Desktop, windows 10.

Merci pour votre aide
Julien
 
Fichiers joints
  • Screenshot 2023-11-12_10-27-36-956.jpg
    Screenshot 2023-11-12_10-27-36-956.jpg
    662.9 KB · Affichages: 17
  • Screenshot 2023-11-12_10-27-54-830.jpg
    Screenshot 2023-11-12_10-27-54-830.jpg
    73.3 KB · Affichages: 18
  • Screenshot 2023-11-12_10-28-16-463.jpg
    Screenshot 2023-11-12_10-28-16-463.jpg
    162 KB · Affichages: 17
Bonjour,
Dans la première image jointe (celle concernant l'ajout de la photo à l'événement Image) et dans la dernière (celle de l'onglet complet), avez-vous remarqué que les noms des fichiers images sont différents ? Dans l'onglet complet, le nom du fichier se termine par (1). Le renommage automatique des illustrations éviterait ce problème. Je reconnais qu'au début, laisser une machine mettre des noms à des fichiers images alors que l'on s'est fixé des règles de nommage (bien structurées ou pas, d'ailleurs) est déroutant, mais le renommage automatique fonctionne très bien.
 
j'ai pris le parti de recommencer à zéro, en sauvegardant ma généalogie sans les images, me permettant de nettoyer une base de données pleine de liens cassés.
Je pense que sauvegarder une généalogie sans les images (et la restaurer), ne supprime pas les anciens liens vers les images, mais conserve des "liens morts" parce que les images ne sont plus là.
Il y avait certainement une meilleure solution (rechercher les images manquantes par exemple ou utiliser le renommage automatique).
 
Sur une des images présentée, les onglets Médias et Complet sont tous les deux sélectionnés, c'est curieux !
En effet le renommage auto est extrêmement pratique surtout que l'on peut définir le modèle des noms.
Ce qui m'inquiète le plus c'est que le problème est sur MAC et cette configuration a été beaucoup moins testée. Mais certains utilisateurs très "pointus" utilisent cette configuration ; ils vous diront sûrement si il y a un problème de ce coté (ce qui m'étonnerait tout de même).
 
Alors tout d'abord merci pour vos réponses rapides et pertinentes.

- J'ai tenté le paramètre qui renomme les fichiers automatiquement, sans changement dans l'affichage des images
-La sauvegarde en décochant la case "illustration" m'a permis de supprimer tous les liens images. une mauvaise gestion des médias m'avaient valu d'avoir des milliers de "liens morts", cette sauvegarde m'aura au moins permis de nettoyer ma base. Ceci étant j'ai conservé une sauvegarde avec les illustrations

-Je viens de voir en effet que ces 2 onglete Medias et Complet sont sélectionnés simultanément

-Ce qui me semble le plus curieux c'est que lorsque les médias restent à leur place, cela fonctionne. Mais quand c'est le logiciel qui gère cela ne fonctionne pas!

Merci pour vos retours en tout cas
 
Fichiers joints
  • Screenshot 2023-11-12_12-39-52-243.jpg
    Screenshot 2023-11-12_12-39-52-243.jpg
    349.8 KB · Affichages: 6
-Je viens de voir en effet que ces 2 onglete Medias et Complet sont sélectionnés simultanément
Est-ce que ce ne serait pas dû à Parallel Desktop, je ne peux pas dire car je n'ai pas de Mac.
-Ce qui me semble le plus curieux c'est que lorsque les médias restent à leur place, cela fonctionne. Mais quand c'est le logiciel qui gère cela ne fonctionne pas!
En effet c'est curieux, cela me laisse penser que le répertoire Images utilisé n'est peut-être pas celui qui est dans le dossier de la généalogie. Dans une de vos première images, il semble que votre dossier s'appelle Jules 2023.GW3. Este ce que vous pouvez regarder dans le répertoires Jules 2023.GW3 \ Images si vous trouvez un fichier PASCAL_Louis_Imag.jpeg (.jpeg me semble curieux, j'aurais plutôt vu .jpg, mais bon).
- J'ai tenté le paramètre qui renomme les fichiers automatiquement, sans changement dans l'affichage des images
Si les images ont été supprimées, Généatique ne peut pas les renommer, je ne comprends pas bien ce que vous avez fait.
 
Est-ce que ce ne serait pas dû à Parallel Desktop, je ne peux pas dire car je n'ai pas de Mac.
J'y ai pensé, mais le fait que ça fonctionne en laissant les médias à leur emplacement me fait dire que ce n'est pas parrallel desktop le problème.
J'avais essayé un autre émulateur, VMWAre fusion avec lequel je n'avais pas ce problème, sauf que VMWare ne supporte pas Icloud et que toutes mes données sont sur..... icloud.
En effet c'est curieux, cela me laisse penser que le répertoire Images utilisé n'est peut-être pas celui qui est dans le dossier de la généalogie. Dans une de vos première images, il semble que votre dossier s'appelle Jules 2023.GW3. Este ce que vous pouvez regarder dans le répertoires Jules 2023.GW3 \ Images si vous trouvez un fichier PASCAL_Louis_Imag.jpeg (.jpeg me semble curieux, j'aurais plutôt vu .jpg, mais bon).
Alors quand j'enregistre une image, elle atterrit bien dans le dossier 'Images' de ma généalogie Jules 2023
Si les images ont été supprimées, Généatique ne peut pas les renommer, je ne comprends pas bien ce que vous avez fait.
Non, je disais juste que j'avais modifier les paramètres dans la gestion des médias afin de renommer les nouvelles images insérées comme vous me le conseillez, mais que ça ne changeait rien à mon problème.
 
Certains formats d'images ne sont peut-être pas compatibles avec Généatique. Essayez d'ajouter une image en utilisant la capture d'écran de Généatique (Alt+K si 2 écrans, ou Shift+Alt+K si un seul écran).
 
Certains formats d'images ne sont peut-être pas compatibles avec Généatique. Essayez d'ajouter une image en utilisant la capture d'écran de Généatique (Alt+K si 2 écrans, ou Shift+Alt+K si un seul écran).
Pas mieux en procédant ainsi.

Afin de bien préciser mon propos, lorsque j'ajoute une image, l'éditeur s'ouvre, et ma photo apparaît bien à ce moment là. Et quand j'enregistre l'image, elle va bien se loger dans le dossier Images (ou j'ai également dans un dossier cible en dehors, avec un résultat similaire). Par contre la vignette ne s'affiche pas, j'ai seulement le chemin de l'image et rien d'autre.
 
Alors non, ma base de données est sur la partition windows, générée par l'émulateur.
Ce sont mes données (actes, photos etc) qui sont sur le cloud.
Je ne comprends plus, si vos images (photos, actes...) sont sur un Cloud et que votre base est sur votre disque local, ces images ne peuvent pas être dans le répertoire Images de la généalogie (Jules 2023.gw3\images.
Peut-être pourriez-vous joindre une copie d'écran de la liste des Illustartions donnée par le Dictionnaire des données (10 ou 15 lignes suffisent), on y verra plus clair
 
Désolé, je n'ai pas été très clair probablement.

Mon installation est la suivante:
- Je travaille sur Mac
- J'utilise l'émulateur parralle desktop avec windows 10 installé dessus.
- Généatique est installé sur cette partition, et les dossiers associés à généatique également (répertoires par défaut lors de l'installation)
- Mes documents, photos, actes sont stockés sur icloud (et parrallel contrairement à vmware, me permet d'acceder à mon cloud pour aller rechercher mes documents)

A ce jour je n'ai pas de liste d'illustrations puisque j'ai tout supprimé lors de ma sauvegarde sans illustrations.
J'ai mis deux images pour l'exemple et je vous ai fait une copie d'écran.
 
Fichiers joints
  • Screenshot 2023-11-12_15-37-59-072.jpg
    Screenshot 2023-11-12_15-37-59-072.jpg
    83.9 KB · Affichages: 6
J'avais mal compris, je suis désolé, donc vos images sont dans le bon répertoire en local dans votre généalogie, et pour insérer une image vous allez la chercher sur le Cloud. Donc de ce côté pas de problème.
Donc vous devriez voir les images.
Est-ce que vous pouvez faire une copie d'écran de l'onglet Gestion des médias pour voir si tous les paramètres sont corrects ?
 
Donc, vous avez choisi de laisser Généatique gérer les médias, de les placer dans le dossier Images de la généalogie et que le renommage soit fait par Généatique.
J'ai la même configuration, sauf pour le format des noms, le votre donne un nom assez long et je ne suis pas certain qu'il soit nécessaire de mettre la date complète et le lieu complet (l'année et la ville sont peut-être suffisants ou seulement la date de l'événement).
Mais....les noms des deux fichiers images que vous montrez dans le résultat du dictionnaire des données ne me semble pas correspondre à ce modèle. Ce sont de portraits et donc le nom devrait se terminé par _img et pas par _imag.
Comment avez-vous insérer ces portraits ?
 
Pas de soucis,

Je vous joins une copie d'écran de ma configuration médias
J'ai comparé sur mac je suis configuré pareil sauf que mes généalogies se trouvent sous Parallels à :
C:\Users\Jean\Documents\Généatique\Mes généalogies

media.jpg
pour vous il apparait cette différence dans le dossier de votre choix le chemin
\\Mac\Home\Documents\Généatique\Mes généalogies
Vos généalogies sont elles sous C: ? ou partagé
 

gratuit

Retour
Haut