• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Perte des Illustrations

Bonjour
Lors d'une matinée de travail hier, sur Génétique 2022, j'ai :
- Saisie une soixantaine de personnes
- ajouter des illustrations
- Fusionner des fiches
- Puis lors de ces saisies je pensais avoir une incohérence sur deux individus...
- après divers contrôles et recherches, pour essayer de résoudre mes soucis,
- J'ai procédé à une réparation Niv 2 et également à une restructuration du dossier.

En fait je n'avais pas d'incohérence, mais une situation familiale complexe… (trop compliqué à expliquer ici).

Puis, j'ai constaté que toutes les illustrations affectées avaient disparues, pour tous les individus de la généalogie (5000 documents) !
Dans supprimer "les médias non utilisés" on retrouvait tous les documents non affectés
Je suis incapable de préciser à quel moment ce problème, c'est produit au cours des différentes manipulations.
Mais il est bien réel !
(c'est génétique qui gère les illustrations automatiquement)
Heureusement, je ne sais plus à quel moment, mais j'avais effectué une sauvegarde saine.
J'ai récupéré l'ensemble de la généalogie.

La seule autre anomalie que j'ai constaté, dans la base "vérolée", j'ai le même document pour un individu, 19 fois dans "images", fichiers qui ont tous la même date, heure, minute ! Numérotés (*), Problème apparu d'après la date fichier, une semaine avant.

Tout cela pour info.
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
Toujours faire une sauvegarde avant une "Réparation" ; dans certains cas la réparation est destructrice..
Pour l'image répétée 19 fois, je n'ai vraiment pas d'explications ; le logiciel a dû rentrer dans une boucle.
 
Oui les sauvegarde sont les seules façons de ne pas ? ?
?
Et vous ne le direz et ne le répèterais jamais assez !
Un complément d'information, malgré l'absence des illustrations dans l'onglet média, l'affichage de l'état des évènements était correcte dans les arbres !
 
Eh bien, c'est beaucoup plus grave que prévu !
J'ai à nouveau perdu toutes les illustrations!!!!
J'ai heureusement pris toutes les précautions qu'il me semble souhaitables !
Donc j'ai sauvegardé, renommé...
Travaillé et testé sur des bases identiques, mais dupliquées.
Et donc systématiquement si je fais une réparation Niv 2, je perds les illustrations comme décris plus haut !
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
....
Et donc systématiquement si je fais une réparation Niv 2, je perds les illustrations comme décris plus haut !
Cela concerne-t-il toutes les fiches, toutes les illustrations ?
Quels chemin ssont donnés si vous faites "Utilitaires/Illustrations/Liste des médias" ?
 
Merci de votre aide.
Je croyais que cela concernait toutes les illustrations main non, La réponse à votre question n'est pas simple.
Le chemin dans le menu Liste Illustration n'est pas complet, on voit "Images\*.jpg......"

- Dans la généalogie buguée N°1, dans "images" 13 fichiers par le menu Liste dans Images, sur les 4903 fichiers existants réellement dans le répertoire images de cette généalogie
- Dans la généalogie buguée N°2, dans "images" 13 fichiers par le menu Liste dans Images, sur 4881 fichiers existants réellement dans le répertoire images de cette généalogie

- Dans la généalogie saine restaurée, dans "images" de la généalogie 4881 fichiers

Sinon écran paramétrage joins.
 
Fichiers joints
  • 00 Capture 1.JPG
    00 Capture 1.JPG
    140.2 KB · Affichages: 11
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
Rien çà dire coté option des médias.
Les chemins Images\xxxxxx.jpg sont corrects, c'est une adresse relative. Dans l'onglet Médias ou Complet vous avec le chemin complet dans la ligne "état aide". Je n'ai jamais vu autant de chemins qui disparaissent ; il doit y avoir un gros problème dans cette base de donnée. Souvent une extraction de toutes les fiches vers un nouveau fichier remet les choses en place. !
Coté généalogie, combien avez vous d'images dans le dossier Images de la généalogie (à voir avec l'explorateur de fichiers) ?
 
Rien çà dire coté option des médias.
Les chemins Images\xxxxxx.jpg sont corrects, c'est une adresse relative. Dans l'onglet Médias ou Complet vous avec le chemin complet dans la ligne "état aide". Je n'ai jamais vu autant de chemins qui disparaissent ; il doit y avoir un gros problème dans cette base de donnée. Souvent une extraction de toutes les fiches vers un nouveau fichier remet les choses en place. !
Coté généalogie, combien avez vous d'images dans le dossier Images de la généalogie (à voir avec l'explorateur de fichiers) ?
Merci pour votre réponse
4881 fichiers comme indiqué plus haut.
Dès que j'ai le temps, je vais sans doute essayer de faire une extraction complète des fiches.....
On verra bien...
 
Pour faire suite :
J'ai fait une extraction complète des fiches vers une nouvelle généalogie (en remplaçant la structure DCH de la nouvelle, plusieurs champs spécifiques).
Reparamétrage des événements équivalents.
Tout c'est bien passé, et j'ai tout récupéré.
Multiples essais des diverses réparations tout niveau, restructuration…
Aucuns soucis
Donc base à nouveau saine, mais sans réellement comprendre la source du problème original.
Merci et Bonne soirée
 
Membre
Ambassadeur Généatique
Bonjour.
Je rencontre un problème similaire de perte d'affichage des média-illustrations-photos-documents, avec l'une des deux généalogies que je gère. Aussi vais je utiliser le même fil de ce forum.

Incident constaté le 12/05/22 = après les 2 màj windows11 du 11/05 (KB5013628 & KB5013943)>> un lien?
J'utilise G.2022 V 3.3.0
Sur ma 1ère généa de 12.600 personnes, aucun problème.
Sur ma 2de de 11.500 personnes, tout est parti en vrille: plus possible de voir à l'écran mes images associés (12.900 éléments bien présents pourtant, dans le répertoire Images).

Pour l'anecdote c'est en saisissant 5 images le 12/05 (toujours bien archivées dans le répertoire images) que je me suis rendu compte qu'elle "disparaissaient" après la saisie... comme toutes leurs grandes soeurs déjà saisies.

Ma dernière sauvegarde complète date du 08/04/22 et j'ai bien entendu beaucoup travaillé depuis.
Je suis passé par toutes les possibilités de réparation (optimisation, restructuration, mise à jour des tables de dupli); sans succès.
En PJ, le tableau de "gestion des media" dans "préférences pour cette généalogie"

Une idée, docteur?
 
Fichiers joints
  • 20220519 geneatique gestion des media.jpg
    20220519 geneatique gestion des media.jpg
    157.1 KB · Affichages: 9
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
Et pouvez-vous nous montrer les 10 ou 15 premières lignes de ce que vous avez en faisant "Utilitaires/Illustrations/Liste des médias" ?
 
Membre
Ambassadeur Généatique
10 ou 15 lignes ? J'aurais bien voulu. mais je n'en vois qu'1 seule !
pour : utilitaires/illustrations/liste des medias
puis 1) choix de la rubrique 2) liste de remplacement (cf PJ unique)
 
Fichiers joints
  • 20220519 1514 liste des media.jpg
    20220519 1514 liste des media.jpg
    225.5 KB · Affichages: 12
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
Ca c'est plus inquiétant car la base de données n'a plus de liens vers les médias alors que je suppose que le dossier Images dans la généalogie a toujours ses illustrations (vérifiez le avec l'explorateur de fichiers). Si c'est bien le cas, je ne vois guère qu'une sauvegarde pour remettre les choses en place. Votre dernière sauvegarde date de plus d'un mois, c'est très risqué de ne pas en faire plus souvent
 
Membre
Ambassadeur Généatique
Gasp! On s'oriente donc vers le constat d'une perte sèche du travail effectué depuis 1 mois.
Je pense à une alternative pour ne pas perdre ce mois de saisie de données (161 personnes créées + les modifs des autres). Et tant pis pour les images récentes...
1°) Effectuer des copies de ma généalogie d'aujourd'hui et de ma sauvegarde d'il y a un mois
2°) Effectuer une fusion de ces 2 nouvelles généalogies
Qu'en dites vous?
PS: à tout hasard, je dois mentionner un fichier d'export gedcom du 1er mai toujours dispo
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
Fusionner deux généalogies de 11500 personnes est certes possible mais ça reste toujours délicat. Vous pouvez essayer à condition de faire une sauvegarde (voire 2) de la généalogie qui va recevoir les fiches.
Pour le gedcom, tout dépend de ce que vous avez exporté dans ce gedcom ; si toutes les rubriques et Notes y sont ça peut être une bonne solution, les images étant faciles à remettre dans la généalogie importée mais ce gedcom est déjà assez ancien. Là aussi vous pouvez faire l'essai si la généalogie importée à un nom différent il n'y a pas de risque d'écraser les généalogie déjà existantes.
La vraie solution aurait été de faire une sauvegarde au moins une fois par semaine de travail et sur au moins deux supports différents.
 
Membre
Ambassadeur Généatique
Problème résolu, au bout d'une semaine de reconstruction de ma généa= analyse, restauration, extraction, fusions.
Merci pour vos conseils, sur ce fil ou ailleurs sur le forum
 

gratuit

Haut