• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Encodage ANSEL de "è" dans les Gedcom [RESOLU]

Membre actif
Je reviens avec mon problème de disparation des caractères "è" après export/import sur Généanet, alors que les autres caractères avec signes diacritiques passent bien.

Précisions : l'export est bien fait en ANSEL et français, cf extrait suivant
Code:
1 CHAR ANSEL
1 SUBM @SUB1@
1 DATE 03 DEC 2013
1 FILE Pays-Sommet_03-12-2013.zip
1 LANG FRENCH
qui montre bien que c' est ANSEL qui a été utilisé comme codage

J'ai remarqué que dans le gedcom le "è" était encodé comme "\'E8" .

Cet encodage du caractère "è" me parait correct.

Il doit donc y avoir un problème dans le contexte qui entoure les notes.
Est ce un problème d'encodage gedcom (ou RTF) par généatique, ou un problème de décodage par Généanet ???

Je viens de soumettre la question du côté Généanet.

Complément (qui au passage donne une idée de la gestion RTF par Généatique :wink: )
La note complète dans le Gedcom généré :
Code:
2 NOTE  #.#RTF
3 CONC {\rtf1\ansi\deff0\uc1\ansicpg1252\deftab720{\fonttbl{\f0\fnil\fcharset
3 CONC 1 Arial;}{\f1\fnil\fcharset1 Calibri;}{\f2\fnil\fcharset0 Calibri;}{\f
3 CONC 3\fnil\fcharset2 Wingdings;}{\f4\fnil\fcharset2 Symbol;}}{\colortbl\re
3 CONC d0\green0\blue0;\red255\green0\blue0;\red0\green128\blue0;\red0\green0
3 CONC \blue255;\red255\green255\blue0;\red255\green0\blue255;\red128\green0\
3 CONC blue128;\red128\green0\blue0;\red0\green255\blue0;\red0\green255\blue2
3 CONC 55;\red0\green128\blue128;\red0\green0\blue128;\red255\green255\blue25
3 CONC 5;\red192\green192\blue192;\red128\green128\blue128;\red0\green0\blue0
3 CONC ;}\wpprheadfoot1\paperw11906\paperh16838\margl601\margr697\margt828\ma
3 CONC rgb493\headery720\footery720\ftnbj\sftnbj\sftnrstcont\nocolbal\sftnnar
3 CONC \saftnnar\fet0\endnhere\sectdefaultcl{\*\generator WPTools_6.170-PRM;}
3 CONC {\plain\f1\fs22 PEYRAVERNE Fran\'E7ois n\'E9 le 18\f2  novembre 1663\p
3 CONC ar
3 CONT \plain\f1\fs22 fs de Sebastien & Jeanne MOUNIOULOUX de Goyet\par
3 CONT \p
3 CONC lain\f1\fs22 parrain : Fran\'E7ois PEYRAVERNE fr\'E8re du dit Sebastie
3 CONC n, \par
3 CONT \plain\f1\fs22 marraine : Clauda DUPLAY de Montcoudiol paroiss
3 CONC e de St-Didier.\par
3 CONT \plain\f1\fs22\'A0\par
3 CONT \plain\f1\fs22 DES HORTZ cu
3 CONC r\'E9\par
3 CONT \pard\plain\plain\f1\fs22\par
3 CONT }}
 
Membre expert
Modérateur
BétaTesteur Généatique
papo4334":1gwxsbv7 a dit:
....Complément (qui au passage donne une idée de la gestion RTF par Généatique :wink: )
Dans le modèle standard d'export vers GeneaNet (modèle restauré), les Notes sont au format .txt et non .rtf ; cela intervient peut-être dans votre problème.
 
Membre actif
predigny":17kntezw a dit:
papo4334":17kntezw a dit:
....Complément (qui au passage donne une idée de la gestion RTF par Généatique :wink: )
Dans le modèle standard d'export vers GeneaNet (modèle restauré), les Notes sont au format .txt et non .rtf ; cela intervient peut-être dans votre problème.

C'est possible, mais de mémoire je ne crois pas.
Le problème est que RTF est possible des deux côtés (Généatique et Génénanet) et qu'il m'est vraiment utile pour de la mise en forme des notes (notamment, gras, italique et souligné).

Par ailleurs cela n'enlève rien à la présence d'un bug d'un côté ou de l'autre (disparition des "è" et pas des autres lettres accentuées). C'est justement ce que je recherche à identifier.

Merci de faire suivre le problème au CDIP. Peut-être auront il une idée ?

De mon côté, je tiendrai informé de la réponse Généanet.
 
Membre expert
BétaTesteur Généatique
Je ne comprends pas tout, là non plus. Malheureusement, je n'ai aucun moyen de vous aider, ne publiant pas sur généanet.
Votre gedcom est exporté en ANSEL. Cependant, votre extrait de code indique un encodage ANSI (2ème ligne). Une harmonisation peut peut-être être une solution.
 
Membre actif
phicome":1giq9lbt a dit:
Je ne comprends pas tout, là non plus. Malheureusement, je n'ai aucun moyen de vous aider, ne publiant pas sur généanet.
Votre gedcom est exporté en ANSEL. Cependant, votre extrait de code indique un encodage ANSI (2ème ligne). Une harmonisation peut peut-être être une solution.

En effet.
Je précise que l'extrait de code est celui généré par Généatique sans aucune manipulation.

C'est peut être bien là que se situerait le problème (donc coté Généatique/CDIP)...
encore que
1. ansel n'est pas supporté par la spec RTF 1.5
2. le "ansicpg1252" qui suit, semblerait préciser que ce n'est pas ANSI pur et dur, mais le ANSI "étendu Windows" pour la gestion des caractères au delà de ANSI (en gros cela précise la table de conversion vers Unicode)
et que ce soit la manière standard de RTF (une belle merde, au passage) de préciser l'utilisation d'autre chose que ANSI pur et dur.

Remarque : la norme RTF 1.5 stipule que le contrôle "\ansicpgN", si utilisé, doit immédiatement suivre le "\ansi", ce qui n'est manifestement pas le cas. Serait ce là le bug ?
EDIT : je viens de faire le test en modifiant le gedcom "à la main" pour mettre les deux "contrôles" dans l'ordre conforme à la spécification (l'un derrière l'autre) : cela ne change rien.

Mais pourquoi les autres caractères accentués (autre que le "è") sont ils traités et représentés correctement par Génénanet ????
 
Membre actif
Complément :

En cherchant un peu dans le standard RTF 1.5, j'ai trouvé que le 1252 du ansicpg1252, n'était pas un des codes valides supportés par le standard, j'ai essayé en remplaçant "à la main" ce 1252 par 863 qui est supposé être le "canadien français", cela ne change toujours rien pour le "è".

J'ai également fait un test en supprimant toute la partie de l'entête RTF concernant les tTAB et les couleurs : pas de changement.

J'ai également fait le test en modifiant le rtf pour remplace /ansi par /pc et en ne mettant pas du tout de /ansicpg : cela ne change toujours rien : les autres caractères accentués passent bien, et toujours pas de "è".

le bug semble bien venir de Généanet.

EDIT: c'est confirmé par JLM, lui même, le bug sera bientôt corrigé sur Généanet. :wink:
 

gratuit

Haut