• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Encore la recherche de parents ...

Membre actif
Ce mail s'adresse plus aux développeurs de GENEATIQUE.

Je viens de dépouiller une année d'actes de naissance et ... surprise ... :wink:
La récente fonction de recherche de parents n'est toujours pas au point :
- Le nom supposé du père s'affiche toujours vite :)
- Lors de la saisie du prénom (c'est là le premier problème) je ne tape pourtant qu'avec 2 doigts mais le curseur n'en fait qu'à sa tête (par exemple la saisie de : Jean Marie, devient quelque chose du genre : ariJean M) :mrgreen: Je rectifie, parfois après 2 ou 3 essais (en essayant de saisir plus lentement)
- Je clique sur "recherche" et là ça mouline ... avant de me rendre la main
- Curieusement, je ne semble pas avoir le même problème avec la mère. :)
- Lors de la validation du couple, ça mouline à nouveau. :(
- Je dois ajouter que la recherche simple d'individu fonctionne sans problème, avec parfois un délai de quelques secondes s'il y a parfois plus d'une centaine de propositions.
J'utilise la dernière version de GENEATIQUE 2015. avec Windows 8.1, 8G de RAM. certes avec un processeur un peu ancien (5 ans). J'ai à la dernière sauvegarde, 55 422 fiches et bien sûr quelques noms équivalents. la dernière optimisation a moins de 24 heures.

Suis je trop exigeant ? Ais je une machine obsolète ? Est ce GENEATIQUE qui n'est pas au point ? J'ai l'impression que le phénomène s'aggrave après un certains nombre de saisies. Y a t il une solution ?

Ah ! Si l'utilisateur pouvait choisir ou non l'utilisation de cette fonction que je persiste à ne pas apprécier.

Merci de m'avoir lu.

Jean-François CROHAS
 
Membre actif
Bonsoir,

J'ai fait des essais, je ne rencontre plus ce problème de prénoms exotiques.

Cependant, si vous avez enregistré un prénom et que vous voulez changer le patronyme du père ou de la mère, ça mouline pendant un bon moment avec l'initiale du nouveau patronyme en minuscule puis lorsque l'on peut reprendre la main, il faut aller dépolluer les dernières saisies de noms.
C'est toujours aussi peu ergonomique et je suis comme vous, je ne trouve aucun avantage à ce nouveau mode de saisie des parents. Mais on en a déjà longuement débattu ici et on n'a toujours pas le choix, je crains donc que ce soit un voeu pieux.

:idea: Une question aux développeurs : Pourquoi dans le formulaire d'ajout des parents, lorsque l'on inscrit l'initiale des prénoms suivant le premier, le curseur se repositionne-t-il systématiquement en début de champ ?

C'est un mystère pour moi car ce n'est pas le cas lorsque l'on crée un enregistrement dans la zone de saisie de la fiche simple, ni dans celles d'ajout des enfants et des frères et soeurs.
 
Membre expert
Modérateur
BétaTesteur Généatique
pguibert":tlfnh0d5 a dit:
.... :idea: Une question aux développeurs : Pourquoi dans le formulaire d'ajout des parents, lorsque l'on inscrit l'initiale des prénoms suivant le premier, le curseur se repositionne-t-il systématiquement en début de champ ?...
Lors des béta-tests, nous avions signalé au cdip que dans la fonction d'ajout des parents il se passait des choses anormales dans la saisie des prénoms, en particulier pour la saisie du deuxième prénom. L'anomalie principale étant le retour de la position du curseur en début de champ pouvant provoquer des saisies du genre "erreJean Pi" ; le défaut était particulièrement visible en cas de touche appuyée simultanément. Mais le cdip n'a pas pu reproduire le problème qui dépend visiblement du type de machine (j'ai un pc où c'est observable, et un autre où il n'y a pas ce problème)
Par contre, dans tous les cas, on observe bien un bref retour du curseur en début du champ Prénom lors de la frappe du premier caractère du second prénom, mais le curseur revient très vite à la bonne position. Cependant ce comportement révèle un problème potentiel et on ne le retrouve pas dans l'édition des prénoms des autres fonctions.
Autre remarque, ce bref retour du curseur, n'est visible que si un nom est présent dans le champ Nom.
Une chose est certaine, il y a dans certains cas, un problème avec cette édition des prénoms. Personnellement je n'ai pas trop de problèmes mais l'on voit facilement que ce champ "Prénoms" de l'ajout des parents ne se comporte pas comme dans les autres fonctions qui utilisent ce champ.
 
Membre actif
predigny":3rrhporf a dit:
Par contre, dans tous les cas, on observe bien un bref retour du curseur en début du champ Prénom lors de la frappe du premier caractère du second prénom, mais le curseur revient très vite à la bonne position. Cependant ce comportement révèle un problème potentiel et on ne le retrouve pas dans l'édition des prénoms des autres fonctions.
C'est pourquoi je pose la question. Il doit y avoir un bout de code indésirable qui fait revenir le curseur en début de la zone de saisie après la frappe de la majuscule des prénoms suivant le premier. Est-ce si sorcier de le dénicher ?

predigny":3rrhporf a dit:
Autre remarque, ce bref retour du curseur, n'est visible que si un nom est présent dans le champ Nom.
Cela rejoint mon observation relative au fait que le logiciel mouline si après avoir enregistré un prénom du père on veut changer le nom (cas d'un enfant illégitime dont le père est identifié sans que l'enfant porte le même patronyme).
Il y a donc une interaction entre le nom et le prénom vraisemblablement due à la fonction de recherche. Comme quoi l'automatisation à outrance n'est pas forcément une bonne chose.
 
Membre actif
On est bien d'accord ...

J'ajouterais une observation, sous réserve de vérification : Ce phénomène de retour au début, semble se produire après plusieurs saisies, donc recherches. Comme si une sorte d'accumulation de recherches provoquait ce phénomène.
Je reprends mes dépouillements dans quelques dizaines de minutes, je vais essayer d'observer l'évolution

Jean-François CROHAS
 
Membre actif
jfcrohas":226e5m0z a dit:
J'ajouterais une observation, sous réserve de vérification : Ce phénomène de retour au début, semble se produire après plusieurs saisies, donc recherches.
Je viens de lancer Généatique, créer un personnage fictif et entrer le père. Le curseur est revenu au début dès la saisie du second prénom du père.
Il n'y a dons pas eu d'accumulation de recherches dans mon cas.
 
Membre actif
Curieusement :
1 - Le problème ne semble pas se produire en saisissant la mère en premier. :D
2 - Je reviens sur ma proposition précédente : dès la première saisie sur le père, BOUM ... :mrgreen:

Que les développeurs résolvent rapidement ce problème qui gâche la vie. Ou qu'ils permettent aux utilisateurs de ne pas utiliser cette fonction, à défaut de la supprimer dans l'attente d'un développement satisfaisant.

Une réponse de leur part sur cet échange serait la bienvenue. Bien préférable aux torrents de mails de pub émanant du CDIP pour studio-scrap et autres bêtises.

Jean-François CROHAS
 
Membre actif
jfcrohas":549x7sbq a dit:
Le problème ne semble pas se produire en saisissant la mère en premier. :D
Pour ce qui me concerne, c'est exactement pareil, que ce soit le père ou la mère.

jfcrohas":549x7sbq a dit:
Que les développeurs résolvent rapidement ce problème qui gâche la vie. Ou qu'ils permettent aux utilisateurs de ne pas utiliser cette fonction, à défaut de la supprimer dans l'attente d'un développement satisfaisant.
Je ne peux qu'approuver cette suggestion.

jfcrohas":549x7sbq a dit:
Une réponse de leur part sur cet échange serait la bienvenue. Bien préférable aux torrents de mails de pub émanant du CDIP pour studio-scrap et autres bêtises.
Vous être très optimiste pour la réponse. :mrgreen:

S'agissant des torrents de mails de pub, ça va directement à la poubelle.
 
Membre expert
Modérateur
BétaTesteur Généatique
Disons tout de même que je ne rencontre pas un problème aussi sévère que celui décrit par l'initiateur de ce sujet ; J'ai bien le bref passage du curseur en début du champ Prénom ; j'ai aussi un problème quand j'appuie simultanément sur deux touches (le curseur va en début de champ Prénom et y reste pour la suite de la frappe) ; j'ai aussi parfois observé un "moulinage" anormalement long lors de certaines saisies ou modifications de saisie, mais dans l'ensemble ça se passe plutôt bien avec cette fonction d'ajout des parents, mais on sent qu'il y a des choses à améliorer pour la saisie des prénoms en particulier.
 
A
Anonymous
Guest
Non enregistré
Bonjour,

Le problème signaler dans ce sujet , n'a été rapporté par AUCUN utilisateur de Généatique ayant contacter le support technique par mail ou par téléphone.

Ce léger dysfonctionnement qui est sans conséquence sur mon pc, (aller retour plus que furtif sur le premier caractère), est classé non prioritaire.
 
Membre actif
Merci à jerome-cdip.

Jamais signalé au support technique, possible. Mais ce même support technique a t il une idée sur l'origine du problème ? Problème loin d’être uniquement avec un seul utilisateur. Pourquoi uniquement sur cette fonction ? Avec de nombreuses variantes semble t il, selon les utilisateurs. Reste cependant que cette fonction ne semble pas fonctionner correctement depuis son apparition.
Si je dois avoir une action sur ma machine, d'accord mais quelle action ? Ma machine ne présente pas cette "singularité" (de retour chariot intempestif) avec Office 2013 (Word ou Excel) que j'utilise beaucoup. Même si je tape avec deux doigts et regarde fréquemment mon clavier (je sais, j'ai tort, mais à 67 ans après de nombreuses années de cette méthode, je me vois mal changer)
Cordialement.

Jean-François CROHAS
 
Membre actif
jerome-cdip":1f036qgz a dit:
Bonjour,

Le problème signaler dans ce sujet , n'a été rapporté par AUCUN utilisateur de Généatique ayant contacter le support technique par mail ou par téléphone.

J'ai également ce problème décrit par "jfcrohas", et effectivement je n'ai pas contacté le support, car cette fonction d'"ajout de parents" génère ou a généré tant de problèmes qu'il est difficile de décrire chacun d'eux !
Encore plus délicat à résoudre, vues les diverses versions de Windows et de machines.

Je pensais naïvement que le support était attentif aux jérémiades des utilisateurs, mais s'il faut absolument par le support ....

Maintenant la nouvelle version 1195 est disponible, je ne manquerais pas de signaler toutes anomalies au support.
 
Membre expert
Modérateur
BétaTesteur Généatique
jerome-cdip":ai9ghvkh a dit:
...Le problème signaler dans ce sujet , n'a été rapporté par AUCUN utilisateur de Généatique ayant contacter le support technique par mail ou par téléphone.....
Normal ! ce n'est pas un problème bloquant. Les utilisateurs ont seulement une gène quand ils voient apparaitre "iJean ErreP" au lieu de "Jean Pierre". Le problème n'est pas le très bref retour intempestif du curseur en début de champ ; c'est le fait que dans certaines conditions, sur certaines machines, ce retour provoque l'apparition du "iJean ErreP".
Personnellement je n'observe ce problème qu'en cas de touche appuyées simultanément et encore seulement sur deux de mes trois pc (les deux qui ont claviers séparés ; mon pc portable n'a pas ce problème). Pour mémoire je rappelle la séquence qui provoque ce problème :
- je veux saisir Jean Pierre dans Ajout des parents (il faut qu'il y ait un NOM)
- je rentre Jean
- un espace
- et simultanément p et i
- puis erre
- J'obtiens iJean ErreP
Je sais qu'appuyer simultanément sur deux touches n'est pas une bonne chose mais je m'attends à avoir seulement une inversion possible des deux lettres Pi ou Ip mais pas ce iJean ErreP qui montre bien l'action négative de ce retour intempestif ( même bref), du curseur. Certains utilisateurs ont ce problème même sans appuyer simultanément sur deux touches (voir le premier message de ce fil).
La fonction de saisie des prénoms, n'est pas saine dans la version actuelle (1.1.9.5) du moins dans cet Ajout des parents ; partout ailleurs c'est Ok.
 
Membre actif
jerome-cdip":edcmjir6 a dit:
Le problème signaler dans ce sujet , n'a été rapporté par AUCUN utilisateur de Généatique ayant contacter le support technique par mail ou par téléphone.
Ce léger dysfonctionnement qui est sans conséquence sur mon pc, (aller retour plus que furtif sur le premier caractère), est classé non prioritaire.
A quoi sert donc ce forum ? Quand il s'agit d'un problème d'achat, les réponses du CDIP sont promptes ! :evil: :evil:

Vous reconnaissez qu'il y a un dysfonctionnement, alors traitez-le ! :evil: :evil: Ce n'est pas parce qu'il est sans conséquence sur votre pc qu'il l'est sur celui de certains utilisateurs de Généatique 2015.
 
A
Anonymous
Guest
Non enregistré
Bonjour,

Ce forum permet des échanges entre utilisateurs de Généatique.
Il permet l'entraide entre utilisateurs.

Il nous permet également de détecter les éventuels dysfonctionnement qui sont traité en fonction de leur priorité

Le problème évoqué va être traité mais est classé non prioritaire.
 
Membre actif
Bonjour.

Voila qui est enfin dit. Le CDIP n'oublie pas complètement ses utilisateurs. Je considère que cet échange dont je suis à l'origine (mais pas le premier à évoquer ce problème)
Hier, j'ai poursuivi mes saisies et je pense que le problème se produit surtout avec une recherche au delà de 50/75 personnes. J'ai des patronymes (avec variantes) ou des prénoms qui dépassent le nombre de 500 à 800 fiches. Ceci expliquant peut être un "moulinage" disons laborieux.
PS : J'ai essayé de changer de clavier, pas noter de différences significatives.

Espérons que la version 2016 verra la fin des problèmes de cette fonction, je n'ose espérer la disparition de cette fonction :lol: . Mais la possibilité de choisir l'utilisation ou non de celle-ci, serait une bonne chose. :D

Merci de considérer ce sujet comme étant clos.

Jean-François CROHAS
 

gratuit

Haut