• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Geneatique 2013 Export "mes-arbres.net" "Violation d'accès"

Membre
Geneatique 2013 Export vers "mes-arbres.net" => "Erreur violation d'accès" ou "Mémoire insuffisante"

Geneatique 2013 - version 1.0.4, 1.0.5 et 1.06
PC sous Windows 7 64bits
Options d'exportation par défaut.
Base 7500 personnes, 2344 photos ou documents (819 Mo)
(Export toute la base)

En phase Etape 1 : Lecture des fiches :
Violation d'accès à l'adresse 02DB80005 dans le module
'IMGMAN81.DLL'. Ecriture à l'adresse 00000000.
ou
"Erreur mémoire insuffisante"
Durant la phase de lecture des fiches, on constate que la mémoire utilisée par Geneatique 2013 augmente énormément (au départ 105 MB, au moment de l'erreur 1,4 GB)

Si je renomme le répertoire où sont stockés les photos de la base (2344 fichiers, 819 Mo) avant de lancer l'opération, l'exportation vers "mes-arbres.net" se passe bien et le phénomène de consommation de mémoire n'apparait pas.

Attention : Cette opération de renommage n'est pas une opération conseillée. Elle a été réalisée sur une version de test pour analyser le plantage et ne doit pas être reproduite si vous ne maitrisez pas la gestion de fichiers sous Windows.

Si je diminue le nombre de personnes lors de l'export, celui-ci se passe bien mais la mémoire utilisée par Geneatique 2013 qui a augmentée pendant l'export ne diminue pas une fois l'export terminé. Si je relance l'export plusieurs fois avec ce nombre de personnes, l'erreur "Mémoire insuffisante" ou "Violation d'accès.." finit par arriver.

Compléments du 31/10/2012 12-09 :
L'export de cette même base vers "mes-arbres.net" s'effectue sans problème avec Geneatique 2012.
 
Membre actif
Je confirme le problème mémoire (énorme) et la lenteur extrême > 15 min ou plantage (avec une base de 8500 personnes et ~ 2000 photos).
Pour le plantage, je n'ai pas eu le Access Violation, mais un "Erreur lors du transfert du fichier" et "Vérifier votre connexion internet".
Pour la fois très lente mais réussie j'ai pensé à un problème du site mes-arbres.net.
Pour la seconde, après vérification de la mémoire, et d'Internet, je suis quasi certain que c'est G2013 le responsable.

Le problème mémoire commence avant le transfert, dès la phase "constitution de la liste".

Je suis sous Vista avec 2 Go de mémoire.

EDIT : j'ajoute que l'export de la même base avec G2012 se passe bien (même si le transfert est assez long, plus qu'il y a quelques mois)
 
Membre
Compléments du 10/11/2012 14-58 :
Un nouveau test a été fait avec la mise à jour 1.0.6. Il n'y a plus de violation d'adresse mais l'opération aboutit toujours à une erreur "mémoire insuffisante". Je peux fournir un lien au CDIP où se trouve l'ensemble des fichiers de ma généalogie pour la reproduction du problème.
 
Membre actif
Bonsoir
je confirme la mémoire insuffisante et la violation pour une mise à jour
de 45000 personnes avec 2013
J'ai fait une nouvelle tentative avec 2012 et vu la lenteur, j'ai perdu patience et arrêté le processus
Résultat ma base existante sur Mes Arbres est vide
Nous attendrons des jours meilleurs.....
cordialement
Jacques
 
Membre actif
Hello
j'ai à nouveau tenté l'opération via G2012 et mes 43537 personnes
sont à nouveau sur le site de "mes arbres" (1 heure 20 mn)
Nous attendrons encore un peu pour faire l'opération depuis G2013
Bonne soirée
Jacques
 
Membre
Nouvel essai avec Geneatique 2013 version 1.1.0 :

Je tente d'exporter avec toutes les options par défaut sauf le choix "Privé" actif.

Quelque soit la généalogie choisie (par exemple "Rois de France" ou ma généalogie avec 7500 personnes), l'opération s'exécute sans erreur mais à l'arrivée, la généalogie sur le site compte 0 individu.

Par rapport aux versions précédentes de Geneatique 2013 :
- il n'y a plus de plantage !
- dans les versions précédentes, les petites généalogies arrivaient à passer.

Pour l'instant, aucune amélioration sur l'export vers mes-arbres.net.
 
Moderateur
Oui, c'est un problème ! le cdip travaille sur ce point très certainement.
Pour le moment le plus simple est de faire un fichier gedcom avec G2013, aller sur votre compte dans "mes-arbres.net" avec votre explorateur Internet et créer une nouvelle généalogie à partir de ce gedcom.
 
Membre actif
geneliot":3ixt2jre a dit:
Nouvel essai avec Geneatique 2013 version 1.1.0 :

Je tente d'exporter avec toutes les options par défaut sauf le choix "Privé" actif.

Quelque soit la généalogie choisie (par exemple "Rois de France" ou ma généalogie avec 7500 personnes), l'opération s'exécute sans erreur mais à l'arrivée, la généalogie sur le site compte 0 individu.

Par rapport aux versions précédentes de Geneatique 2013 :
- il n'y a plus de plantage !
- dans les versions précédentes, les petites généalogies arrivaient à passer.

Pour l'instant, aucune amélioration sur l'export vers mes-arbres.net.


En faisant un test de remplacer ma généalogie sur mes-arbres-net avec G2013 V1.1.0, l'export (mode public ou privé") est refusé avec le message suivant : "Indice de liste hors limite (-1)"
Si je demande "créer une nouvelle généalogie" alors j'ai bien après un certain temps "export terminé" mais 0 individus dans cette généalogie !!! (au lieu d'un peu plus de 9000).
Confirmation du problème.
 
Membre actif
Compléments,

en refaisant le test ce matin (celui de remplacer ma généalogie puisqu'elle était passé à 0 individus) avec G2013 V1.1.0 , il n'y a plus le message de refus (index hors limites), mais un blocage qui m'a forcer à interrompre en "annulant" l'export... En regardant de plus près, il semble bien que cela vienne d'un problème de gestion mémoire du côté G2013, en effet on observe que la mémoire utilisée augmente, augmente, augmente jusqu'à atteindre le max du PC (mémoire virtuelle comprise)...
Précision : bien que n'ayant aucun problème, j'avais procédé à une restructuration complète avant le test (pour écarter toute cause liée à cette généalogie).

Nota: j'ai donc du recourir à l'import du gedcom pour ne pas laisser mon arbre vide sur le site... et ça marche... :wink:


Après installation de le G2013 V1.1.1 : ça consomme encore énormément de mémoire (trop) pendant la première phase du travail et c'est terriblement lent (les transferts se font, après quelques secondes correctes au début, à nettement moins d'un Ko par seconde !), mais au bout de plus de 15 minutes pour ~9 000 personnes c'est arrivé au bout avec succès. :wink:
Comme cela ne fait pas partie des "correctifs annoncés" avec cette maj V1.1.1.0, on peut supposer que c'est un effet de bord positif de la correction d'un autre bug (avec des effets sur la consommation mémoire).

En bref on ne peut plus dire que ça ne marche pas, mais ça reste quasiment inutilisable en l'état, et il vaut largement mieux continuer avec un export gedcom.
 
Moderateur
papo4334":1hlqb4qp a dit:
....En bref on ne peut plus dire que ça ne marche pas, mais ça reste quasiment inutilisable en l'état, et il vaut largement mieux continuer avec un export gedcom.
Il y a encore plusieurs problèmes avec cette fonction, mais le plus grave me semble être que le contenu des illustrations est exporté ce qui donne un fichier énorme à transférer. Faites l'essai avec une généalogie dont vous aurez supprimé (ou renommé) le répertoire "Images" et les choses se passeront beaucoup mieux. Reste aussi que certaines données que l'on veut exporter (voir Options) ne le sont pas et que d'autres dont on ne veut pas, le sont !
Pour l'instant la création, dans son compte mes-arbres.net, d'une nouvelle généalogie à partir d'un gedcom reste la meilleure solution.
 
Membre
Bonjour,
Nous sommes maintenant fin Mai 2013 et je me rajoute à la longue liste de ceux pour lesquels Mes-arbres.net est devenu inaccessible par exportation directe comme prévue dans Généatique 2013.
C'est d'autant plus navrant que j'ai acheté chaque année depuis 2009 le nouveau logiciel et qu'auparavant l'exportation de mes 12000 fiches ne posait aucun problème!
Aujourd'hui seules 5 figurent sur le site et ne sont même pas reliées entre elles...
Une nouvelle tentative de chargement sous un autre nom donne 0.
ne reste que le gedcom parait-il. En attendant un dépannage qui n'arrive pas j'utilise Geneanet, c'est mieux que le site CDIP... Mon réel objectif est d'ailleurs de publier sur mon propre site mon arbre graphique avec infos et photos, j'espère y arriver avec Geneatique 2013 mais demande à voir.
Cordialement



geneliot":1fd74udi a dit:
Geneatique 2013 Export vers "mes-arbres.net" => "Erreur violation d'accès" ou "Mémoire insuffisante"

Geneatique 2013 - version 1.0.4, 1.0.5 et 1.06
PC sous Windows 7 64bits
Options d'exportation par défaut.
Base 7500 personnes, 2344 photos ou documents (819 Mo)
(Export toute la base)

En phase Etape 1 : Lecture des fiches :
Violation d'accès à l'adresse 02DB80005 dans le module
'IMGMAN81.DLL'. Ecriture à l'adresse 00000000.
ou
"Erreur mémoire insuffisante"
Durant la phase de lecture des fiches, on constate que la mémoire utilisée par Geneatique 2013 augmente énormément (au départ 105 MB, au moment de l'erreur 1,4 GB)

Si je renomme le répertoire où sont stockés les photos de la base (2344 fichiers, 819 Mo) avant de lancer l'opération, l'exportation vers "mes-arbres.net" se passe bien et le phénomène de consommation de mémoire n'apparait pas.

Attention : Cette opération de renommage n'est pas une opération conseillée. Elle a été réalisée sur une version de test pour analyser le plantage et ne doit pas être reproduite si vous ne maitrisez pas la gestion de fichiers sous Windows.

Si je diminue le nombre de personnes lors de l'export, celui-ci se passe bien mais la mémoire utilisée par Geneatique 2013 qui a augmentée pendant l'export ne diminue pas une fois l'export terminé. Si je relance l'export plusieurs fois avec ce nombre de personnes, l'erreur "Mémoire insuffisante" ou "Violation d'accès.." finit par arriver.

Compléments du 31/10/2012 12-09 :
L'export de cette même base vers "mes-arbres.net" s'effectue sans problème avec Geneatique 2012.
 
Membre expert
Bonjour.
Essayer sans photos et illustrations; l'export marche dans ce cas.
J'ai effectué une dizaine d'export total de ma généalogie de 35000 personnes cette semaine sans problèmes.
Bien cordialement.
Joël NIZART
 
Membre
joel-bt":3g8irf9g a dit:
Bonjour.
Essayer sans photos et illustrations; l'export marche dans ce cas.
J'ai effectué une dizaine d'export total de ma généalogie de 35000 personnes cette semaine sans problèmes.
Bien cordialement.
Joël NIZART

Désolé mais pas pour moi, même en oubliant photos et illustrations et je n'ai que 12000 fiches...
Donc pour l'instant je laisse tomber Mes-arbres.net d'autant que j'ai réussi à exporter mes pages htm (photos et illustrations incluses) sur mon site privé où là cela marche très bien. Cherchez l'erreur...
Cordialement
Christian CHOMAT
 
Membre actif
Bonjour.
Je crois pouvoir dire que ce message d'alerte 'Violation d'accès' vient d'un problème de 'Time out'.
'Time out' est un terme technique définissant un problème de délai entre 2 transactions.
Il y a un exemple lorsqu'on consulte les archives départementales et que l'on reste très longtemps sur la mème vue. Lorsqu'on veut, après un délai assez long donc, changer de vue, on reçoit un message d'erreur variable selon les sites. La page sur laquelle on était est alors perdue.
Bien sùr, je peux me tromper, mais...
Cordialement.
 
Membre actif
xchh":1k1zk78x a dit:
...., même en oubliant photos et illustrations et je n'ai que 12000 fiches...
Donc pour l'instant je laisse tomber Mes-arbres.net ....
Cordialement
Christian CHOMAT

Je remonte le sujet "Mes-arbres.net" car rien ne va plus dans ce domaine :
Malgré des annonces triomphantes lors de la dernière mise à jour 1.2.0.5, je constate qu'il m'est impossible aujourd'hui :
- de mettre à jour ma base en ligne depuis geneatique (qui ne "trouve pas la connexion internet" après plusieurs minutes de pédalage... et bien que je sois identifié et loggé sur le site
- de mettre à jour mon arbre en direct dans "mes-arbres.net", ni par envoi d'un ZIP, ni d'un GED (sans illustrations)
- de supprimer mon arbre existant dans "mes-arbres.net" : en effet, celui-ci prétend contenir 76.000 fiches, mais il n'y a plus aucun lien entre elles...
- et donc impossible aussi d'envoyer mon GED pour "créer une nouvel arbre"

Rencontrez-vous les mêmes problèmes et faut-il attendre un débogage général ?
PS... la recherche des sujets qui traitent de Mes-arbres.net avec le moteur de recherche interne du forum donne un résultat pour le moins étrange :mrgreen:
 
Membre
Et oui, toujours impossible ...reste Geneanet gratuit mais sans les photos. Dommage pour un produit qui se veut à la pointe et payant. En tout cas pas question d'acheter la mise à jour suivante de Généatique si rien n'ai fait sur Généatique 2013.
xchh
 
Moderateur
Le cdip à beaucoup "galéré" sur cette fonctionnalité qui est plus ambitieuse qu'elle n'y parait : Une vraie synchronisation et dans les deux sens ! La fonction semble marcher correctement (sans doute avec des problèmes résiduels) mais il y a des précautions à prendre :
- Ne pas exporter les illustrations (voir options de l'export vers mes-arbres) . De toute façon, pour l'instant du moins, les illustrations ne sont pas visibles sur Mes-arbres et sont limitées à 50Mo. Si on exporte les illustrations, le temps de transmission devient énorme.
- Ne pas essayer de synchroniser une généalogie qui était déjà sur Mes-Arbres avant l'apparition de cette fonctionnalité (et même de sa dernière version) ; Il faut, la première fois, recharger entièrement la généalogie (la remplacer).
- Si la généalogie est placée sur Mes-Arbres par l'intermédiaire d'un fichier gedcom, la synchronisation ne fonctionnera sans doute pas bien. Il faut charger la généalogie par les fonctionnalités de la synchronisation vers Mes-Arbres.
- Pour placer sur Mes-Arbres une nouvelle généalogie, il faut utiliser le menu "Fichier/Synchroniser votre généalogie...." ; pour une simple synchronisation avec Mes-Arbre de la généalogie ouverte dans G2013, on peut utiliser l'icône qui est à droite de l'icône "clé usb"
- Si une généalogie ne peut pas être supprimée de Mes-Arbres, c'est sans doute que le serveur est indisponible, ou qu'une fonction de sécurité de votre pc bloque l'accès à Mes-Arbres.
 
Membre actif
Bonjour,
Nouveaux essais avec -enfin- la réussite d'une mise en ligne de ma base :
----------
- Hier :
. j'arrive enfin à supprimer les bribes restantes de généalogies antérieures
. envoi d'un nouveau fichier GED (j'évite le ZIP pour épargner un traitement supplémentaire au serveur :mrgreen: )
. le serveur "bride" la vitesse de téléchargement à moins de 1 mbit/sec., soit à peine 100Mo/s -> 5mn pour télécharger les 27Mo
. le traitement du fichier commence >10% des fiches traitées après 1/4heure
. je suis déconnecté du serveur, le traitement se poursuit jusqu'à 31000 fiches (/85000) et s'arrête ainsi
. HALLUCINANT : le fichier GED envoyé est supprimé de mon disque dur !
-------
Aujourd'hui :
- j'arrive à supprimer la généalogie incomplète
. je lance "optimiser ma base de données", au cas où ->fin catastrophique toutes les dates et événements sont effacés
. reprise à partir de la sauvegarde
. utilitaire "restructurer le dossier généalogique" ->succès apparent ->création d'un nouveau fichier GED (NB: je n'avais pas d'erreur visible dans l'utilisation de ma base auparavant...) - (NB2 : le fichier d'aide est particulièrement abscons pour expliquer l'utilité relative et les différences entre "optimiser" "restructurer et ses 3 options" et "réparer et ses 3 niveaux"...
. envoi réussi du fichier GED (toujours en 5 min..) ... le GED d'origine n'est pas supprimé de mon disque dur...
. traitement et mise en ligne de la généalogie : durée totale du traitement près de 2 HEURES :lol: 8) :roll:
---------
La même opération sur Geneanet prend quelques minutes à partir d'un fichier Zipé >de plus Geneanet signale en fin de traitement les incohérences (événements après décès etc.)
MORALITÉ > le serveur du CDIP est cacochyme tant pour les débits en upload que pour ses capacités de calculs et de traitement : inutile de rêver à une synchronisation permanente à partir du logiciel avec un tel outil !
 
Moderateur
dan_69007":2fyl2k3w a dit:
.... je suis déconnecté du serveur, le traitement se poursuit jusqu'à 31000 fiches (/85000) et ...
Pourquoi passez-vous par un fichier gedcom ? La synchronisation vers Mes-Arbre doit se faire par la fonction "Fichier/Synchroniser votre généalogie avec Mes-Arbre.net" ou "Fichier/Exports/Exporter vers mes-arbres.net" si non les synchronisations ultérieures ne seront pas possibles.
Il est vrai que le premier chargement est très long, mais pendant ce chargement G2013 est opérationnel pour continuer à travailler. les synchronisations ultérieures seront très rapides car seuls les changements seront transférés.
Il est vrai aussi qu'il y a, ou il y avait (?), un problème avec les généalogies de plus de 31000 fiches, le cdip nous a dit que le problème avait été identifié, mais je ne sais pas si c'est dans une nouvelle version de G2013 ou si la modification sera faite dans le serveur du cdip.
Avec cette fonction de synchronisation, il vaut mieux "se faire la main" sur une petite généalogie, mais la fonction semble prometteuse car on peut aussi modifier la généalogie sur Mes-arbres.net et par la suite, synchroniser sa généalogie sur le pc.
 
Membre actif
predigny":36eskg1s a dit:
... ? La synchronisation vers Mes-Arbre doit se faire par la fonction "Fichier/Synchroniser votre généalogie avec Mes-Arbre.net" ou "Fichier/Exports/Exporter vers mes-arbres.net" si non les synchronisations ultérieures ne seront pas possibles. ...c.

Quand j'ai testé cette fonction, "il" m'a dit qu'il ne trouvait pas la connexion internet :mrgreen:
 
Haut