• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Illustrations généatiques introuvables

Bonjour,

J'ai fait une fausse manoeuvre que je ne comprends pas encore. J'ai voulu effacer dans l'écran d'accueil de G19 une généalogie ancienne (genre Famille Volckaert-Maeyns 2018). Malheureusement ceci a effacé toutes les généalogies (donc aussi la version Famille Volckaert-Maeyns 2019). Heureusement j'avais fait une sauvegarde ce matin, j'ai donc pu tout recharger. Ouf !
Malheureusement, toutes les images (photos et documents) de la généalogie sont invisibles. Les petits (v) apparaissent bien là où j'ai un document attestant de la date écrite, mais aucune image.
Quand j'essaye d'aller dans Utilitaire/Illustrations/Copier les illustrations, ça charge puis j'ai une fenêtre qui me dit que les 1100 images sont introuvables. Quand je les cherche manuellement, il en trouve 200 et des poussières, mais ne les charge pas. Je ne pige rien du tout ! Ce système n'est pas du tout instinctif et je ne comprends pas pourquoi les images sauvegardées ne se chargent pas à chaque ré-ouverture. C'est la 2e fois que ça arrive et la 1ere fois j'ai dû tout remettre manuellement...

Quelqu'un a-t-il une idée précise de ce qu'il faut faire?

Merci d'avance.

C
 
Moderateur
Si les sauvegardes ont été faites avec la fonction "Sauvegarder", on récupère la généalogie en utilisant la fonction "Utilitaires/Restaurer/Restaurer votre généalogie". Toutes les illustrations doivent alors y être.
Malgré tout, si il manque les images (par exemple parce que l'on a utiliser un gedcom comme sauvegarde ou simplement dézippé une sauvegarde) on peut retrouver les images comme vous l'avez fait, en semi-automatique en choisissant le dossier "Images sauvegardées/Nom-généalogie.gw2/Images" comme dossier source contenant les images.
 
Bonjour,

J'ai essayé la restauration, mais cela ne fonctionne pas. A la fin du processus, il me dit que le document gw2 n'est pas compatible avec G19 et qu'il faut le convertir, je clique sur OUI et il me dit que c'est impossible car le dossier est endommagé. C'est bizarre car je n'ai jamais eu que G19 et tout ce que j'ai a été fait de là.

Merci encore pour votre réponse et en attente d'une bonne âme qui puisse m'aider encore :)

C
 
Dans le doute, j'ai fait une restauration d'une sauvegarde de mars 2019. Elle a eu l'air de fonctionner, elle s'est chargée sans problème mais il n'y a toujours pas d'images... Bouhouhouuuuuu ;-(
 
Sinon, j'ai essayé aussi la copie des illustrations par recherche manuelle. J'ai le dossier, le programme me dit qu'il n'a pas trouvé 8 photos, mais bien le reste, mais au final il ne charge rien dans G19... un idée?

Pour info, je suis sur Mac avec Parallel Desktop sur Windows 10.
 
Service technique
Membre du personnel
Une autre technique pour restaurer les images :

- Allez par l'explorateur windows dans Mes documents\Généatique\Mes généalogies\xxx.gw2
- Copiez le dossier Images
- Allez dans Mes documents\Généatique\Mes généalogies\xxx-2.gw2.
- Collez le dossier Images
 
Bonjour,

J''ai essayé votre proposition aussi et malheureusement cela ne marche pas non plus. J'ai essayé même de supprimer toutes les illustrations, mais comme elles "n'existent" pas, cela n'a pas marché non plus. Quand je fais Utilitaire/illustrations/... il fait la recherche, trouve 923 photos sur les 1111 qu'il y a, me dit qu'il les a copiées mais elles n'apparaissent pas.
J'en suis à un point de me dire que je vais tout recommencer manuellement et puis on verra... mais j'ai 1780 personnes dans l'arbre.

Merci encore à ceux qui pourront m'aider.
 
Moderateur
c.volckaert4":2ql1ucgg a dit:
...J'en suis à un point de me dire que je vais tout recommencer manuellement et puis on verra...
Non, ce serait une erreur et un gros travail. Ce qu'il faut reprendre à zéro c'est la compréhension de votre problème.
Faites "menu Documents/Dictionnaire des données" et dans la liste de choix (en haut) choisissez la rubrique Illustration. Avec "Toute la généalogie" sélectionnée, cliquez sur le bouton "Afficher la liste". Les chemins de vos illustrations commencent-ils tous par Images\ suivi du nom de l'image ?
Si la réponse est Oui, avec l'explorateur de fichiers de Windows regardez ce qu'il y a dans le dossier "Images" contenu dans la généalogie. En classant les images par Liste et par ordre alphabétique vous devriez retrouver la même liste que celle donnée par le "Dictionnaire des données" ; si non , quelles sont (en gros) les différences ?
 
J'ai regardé ce que vous m'avez dit. Les illustrations sont bien nommées images/le nom de l'image... sauf 7 d'entre elles. Qui commencent par Mac//Home/Desktop/Généalogie/le nom de l'image.
 
Moderateur
c.volckaert4":1yrz6b7e a dit:
S'il n'y a que ces 7 là qui posent problème, je suis disposé à les effacer ;-) avec joie!!
C'est sans doute le plus simple. Pour savoir à quelle fiche appartient la photo, dans la liste donnée par le dictionnaire des données, vous pouvez cliquer sur le bouton "Afficher le détail" (à droite). Il faut supprimer l'illustration à partir de la fiche détaillée de la personne.
 
Bonjour,

J'ai effacé les 7 photos "fautives". J'ai réessayé la "copie d'illustrations" (dans utilitaire), mais même problème.
Voici les print screen.
 
Fichiers joints
  • Capture d’écran 2019-08-09 à 15.59.37.png
    Capture d’écran 2019-08-09 à 15.59.37.png
    28 KB · Affichages: 349
  • Capture d’écran 2019-08-09 à 16.00.02.png
    Capture d’écran 2019-08-09 à 16.00.02.png
    26.4 KB · Affichages: 349
  • Capture d’écran 2019-08-09 à 16.00.10.png
    Capture d’écran 2019-08-09 à 16.00.10.png
    23.5 KB · Affichages: 349
Comment est-ce que cela se fait qu'il me dise qu'il n'y a que 13 photos qui ne sont pas trouvées, mais qu'il ne copie pas les 1000 autres?
 
Moderateur
Je ne comprends pas bien ce qu'il se passe. Il faudrait que j'ai la généalogie entre les mains.
Combien y a t il d'images dans le dossier Images de la généalogie ? (à regarder avec l'explorateur de fichiers de Windows).
Quel dossier avez-vous désigné pour la recherche semi-automatique" de la fonction Utilitaires/Illustrations/Copier.... " ?
 
A qui le dites-vous !! ;-)
Il y a 979 images dans ce dossier-là: \\Mac\Home\Documents\Généatique\Mes généalogies\Famille Volckaert - Maeyns_18-03-19.gw2\Images
 
Moderateur
Mais alors, si je comprends bien, vous êtes sous MAC ! Ce qui sort de mes habitudes ! Si ces images sont bien dans le dossier Images de la généalogie, elle devraient être affichées sans problème dans les fiches de la généalogie. Si elle ne le sont pas je ne vois qu'un problème possible : c'est que Généatique sous MAC n'utilise pas les adresses relatives pour pointer les images. Ca me semble étonnant tout de même. On peut lever le doute en mettant les adresses complètes au lieu des adresse relatives. Pour cela, sur une copie de la généalogie (c'est plus prudent) on va dans le dictionnaire des données/Illustrations et dans la liste des illustrations on fait un cherche-remplace. On cherche Images\* et on remplace par \\Mac\Home\Documents\Généatique\Mes généalogies\Famille Volckaert - Maeyns_18-03-19.gw2\Images\*
Mais il vaudrait mieux que quelqu'un qui connait bien Généatique sous MAC prenne le relais.
 
C'est sous MAC mais j'ai une licence Windows sur laquelle j'utilise Geneatique 2019. Donc c'est le même système que sur PC normalement. Il se trouve qu'il y a certaines images qui sont sauvegardées sous MAC, Dieu sait pourquoi...

J'ai essayé de faire une restauration de nouveau, avec le dossier ZIP le plus lourds (supposant qu'il contenait toutes les images à 1,3Go). Il charge correctement, puis ceci: à la fin du chargement, il me dit que le dossier n'est pas compatible avec G19 (bizarre, alors qu'il a été créé sur G19), qu'il doit être converti, et quoique je fasse (oui ou non), il me répond que le document est endommagé. Qu'est-ce que cela veut dire ? Que faire ?

Merci encore.
 
Fichiers joints
  • Capture d’écran 2019-08-15 à 08.32.25.png
    Capture d’écran 2019-08-15 à 08.32.25.png
    33.7 KB · Affichages: 290
Moderateur
c.volckaert4":3jmssoe8 a dit:
....J'ai essayé de faire une restauration de nouveau, avec le dossier ZIP le plus lourds (supposant qu'il contenait toutes les images à 1,3Go)...
Les sauvegardes faites par la fonction "Sauvegarder" ne placent pas les images dans le fichier .zip mais seulement les données ; les images sont placées dans le dossier "Images sauvegardées\Nom-de-la-généalogie.gw2\Images". Si les images étaient dans le .zip, ça ferait beaucoup de fichiers très lourds avec une redondance inutile des images. Les .zip des sauvegardes doivent être restaurés avec la fonction "Utilitaires/Restaurer/Restaurer votre généalogie" (il y a d'autres accès à cette fonction).
 
Membre actif
Une sauvegarde zip de 1.3Go, cela me paraît énorme, chez moi pour 93000 fiches, les sauvegardes font à peine 100 Mo (et dedans il y a le fichier .adb-old).
 
Moderateur
AL1493":38n9adxi a dit:
Une sauvegarde zip de 1.3Go, cela me paraît énorme, chez moi pour 93000 fiches, les sauvegardes font à peine 100 Mo (et dedans il y a le fichier .adb-old).
Oui, c'est beaucoup, sauf si il y a 20 fichiers -old(n).adb Je supprime ces old alors je ne sais pas comment ils se comportent si on ne les supprime jamais. Si ils s'accumulent et que l'on fait une restructuration toutes les 20 fiches, on arrive vite à 1,3Go !
 
Haut