• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Illustrations non utilisées

Membre actif
Bonjour à tous,
Faisant le ménage dans mes illustrations avec GT2020 avant passage dans GT2021, je viens de découvrir une bizarrerie : les fichiers en *.JPG (JPG en majuscules) ne se suppriment pas via l’utilitaire :
Utilitaires/Illustrations/Supprimer les illustrations non utilisées.
Tout se passe bien si les fichiers sont en *.jpg (en minuscules)…mais s’ils sont en *.JPG = pb !
J’ai réalisé plusieurs essais et les fichiers à supprimer n’étaient plus utilisés dans la généalogie, ce que j’ai vérifié auparavant via le dictionnaire des données qui liste l’ensemble des Illustrations.
Q1 - Constatez-vous la même chose dans GT2020 ?
Q2 - Est-ce la même chose avec GT2021 ?
Jean-Jacques
 
Moderateur
G2020 a en effet un problème avec la détection des images non utilisées. J'ai supprimé un événement Union qui avait deux illustrations en .JPG et G2020 ne les à pas trouvée en "non utilisées". Avec l'explorateur de fichier j'ai mis en minuscule le .jpg de l'une des deux images ; G2020 a trouvée celle en .jpg donc il y a bien ce problème.
G2021, lui, a trouvé les deux.
 
Membre expert
Également constaté le problème et ceci grâce à G2021
J'ai supprimé un événement décès qui avait une illustrations en .jpg et G2020 ne l'a pas trouvée en "non utilisée".
Mon image était pourtant en jpg minuscule.
G2021, lui, a trouvé l'image en trop.
 
Membre actif
Geneatique 2021, premier Plantage !

Jusqu'à présent je ne rencontrais pas de plantage comme les autres utilisateurs ont pu le rapporter, il faut dire que je n'utilise ni le cloud ni géneanet ni rien de tel, toute ma gestion est en local.

Mais j'ai voulu tester cette histoire d'illustrations non utilisées. G2021 m'en a trouvé 38, OK mais lorsque j'ai fait défiler ces images non utilisées (dans la fenêtre proposée), plantage total, CTRL ALT SUP etc......

J'ai tout fermé et retenté l'opération, oui je sais je suis têtu !
Mais cette fois tout s'est bien déroulé. Quelle différence avec la première fois ?
A la première tentative j'avais une image ouverte dans la visionneuse Windows (image concernée par la fonction "illustrations non utilisées").

Une piste à creuser.... je retenterai pour voir.
 
Membre actif
Dans la même veine, toujours en faisant du ménage de GT2020 avant passage à GT2021, j'ai encore une bizarrerie : une image qui est venue je ne sais comment elle a un nom : default.png et elle n'est pas dans mes modèles ! Elle est dans : C:\Program Files (x86)\Geneatique2020 (voir copie d'écran en pièce jointe).
Mon fichier date depuis le tout premier GeneaTique et déjà j'y concentrais des documents texte (Word et PDF), document qui se retrouvait sous un champ "image" ...toutefois ces documents Word était en *.doc avant (maintenant de *.docx).
Voilà plusieurs jours que je cherchais et je viens de trouver...en supprimant (corbeille) ce fichier *.doc, l'image "fantôme" a disparu.
Par contre si je clique sur le fichier en*.doc, il s'ouvre normalement sans aucun blocage.
Toutefois le fait d'avoir cette image (default.png) n'est pas très rassurant.
 
Fichiers joints
  • GT2020_defaut.jpg
    GT2020_defaut.jpg
    305.1 KB · Affichages: 117
Membre expert
Deleau":2uxqp5gu a dit:
A la première tentative j'avais une image ouverte dans la visionneuse Windows (image concernée par la fonction "illustrations non utilisées").
Je pense que le problème venait de là .
Comme on dit en informatique de façon imagée "On ne peut pas scier la branche sur laquelle on est assis"
 
Membre expert
Rien d’anormal d'avoir des png dans : C:\Program Files (x86)\Geneatique2020 .
J'ai aussi au total 9 images png, tout comme dans G2021.
 
Fichiers joints
  • defaultimage.png
    defaultimage.png
    7 KB · Affichages: 90

Annonces

CONCOURS
CONCOURS

Haut