• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe

Média nommage non conforme au modèle ?..

Membre
Bonjour à tous,

J’utilise Généatique 2021 et j’ai laissé la gestion des médias au logiciel.
Cette option ne m’a pas posé de problème jusqu’à maintenant.
Ayant repris des recherches sur une branche spécifique j’ai enrichi certaines fiches de nouveaux médias.
Le nommage du média ajouté s’est correctement passé :

Naissance_TISSIER_Alexis Joseph_1773 média déjà existant dans Images (a)
Naissance_TISSIER_Alexis Joseph_1773 (1) média ajout, correct.(b)

Ayant plusieurs fiches modifiées au niveau des médias, j’ai souhaité avoir un nommage plus parlant à savoir par exemple

Naissance_TISSIER_Alexis Joseph_1773 (c)
Naissance_TISSIER_Alexis Joseph_1773[Associatif]. (d)

J’ai donc supprimé au niveau d’Images les médias d’origine (a) et (b) et les liens au niveau de l’événement.
J’ai associé les deux média un par un à l’événement concerné en fonction de mon modèle de nommage et vérifié que l’emplacement et le nom du fichier étaient corrects, ce qui était le cas comme (c) et (d).

Avant de fermer ma session de travail, je suis allé vérifier via l’explorateur de fichiers Windows le contenu de Images et en tache de fond le logiciel a ajouté le (1) comme ci-après

Naissance_TISSIER_Alexis Joseph_1773 (1)
Naissance_TISSIER_Alexis Joseph_1773[Associatif] (1).

Je pensais que ce type d’anomalie était réglée.

Ai-je oublié une manipulation ?

Je vous remercie de votre éclairage.
 
Service technique
Membre du personnel
Administrateur
Modérateur
BétaTesteur Généatique
Bonjour,

Avez-vous supprimé les médias non utilisés de la généalogie avant de les réassocier ?
 
Membre expert
Modérateur
BétaTesteur Généatique
Normalement si vous avez bien supprimé les images dans le dossier Images il n'aurait pas dû y avoir de (1).
Avez-vous modifié le modèle de nommage, ou simplement joué sur le [complément] ?
 
Membre
Normalement si vous avez bien supprimé les images dans le dossier Images il n'aurait pas dû y avoir de (1).
Avez-vous modifié le modèle de nommage, ou simplement joué sur le [complément] ?
Non je n'ai pas modifié le modèle de nommage, j'ai juste joué sur le [complément]
Bonjour,

Avez-vous supprimé les médias non utilisés de la généalogie avant de les réassocier ?
Bonjour,
Désolé, comment opère-t-on cette suppression ?
 
Membre
J'ai répondu trop vite.
J'ai trouvé le moyen de le faire et parmi les médias (11) supprimés aucun ne correspond à la fiche en question.
Bonjour,
Je reviens sur la discussion, ayant renouvelé plusieurs fois l'opération mais avec le même résultat et sans avoir plus d'explication sur ce phénomène.
Même si je décale dans le temps la réassociation des médias à l'événement, je récupère le (1) intempestif au nom du fichier.
Utilisateur de Généatique depuis 1998 et ayant suivi chaque année les nouvelles versions j'avoue me poser la question pour passer à la version 2022.
 
Membre expert
Modérateur
BétaTesteur Généatique
Si un (1) est ajouté c'est qu'il y a déjà une image qui a ce nom dans le dossier "Images" de la généalogie.
Regardez dans ce dossier avec l'explorateur de fichiers de Windows, en triant les images par ordre de nom, si il n'y a pas deux images pourtant le même nom, l'une avec "nom.jpg" et l'autre "nom (1).jpg".
Même si en informatique un bug n'est jamais impossible, il me semble que celui-là aurait été déjà détecté depuis longtemps.
Quel est votre modèle de nom pour les médias ? Est-il assez complet pour que les homonymes soient quasi-impossibles (Nom+Prénoms+événement+Date complète) ?
 
Membre
Si un (1) est ajouté c'est qu'il y a déjà une image qui a ce nom dans le dossier "Images" de la généalogie.
Regardez dans ce dossier avec l'explorateur de fichiers de Windows, en triant les images par ordre de nom, si il n'y a pas deux images pourtant le même nom, l'une avec "nom.jpg" et l'autre "nom (1).jpg".
Même si en informatique un bug n'est jamais impossible, il me semble que celui-là aurait été déjà détecté depuis longtemps.
Quel est votre modèle de nom pour les médias ? Est-il assez complet pour que les homonymes soient quasi-impossibles (Nom+Prénoms+événement+Date complète) ?
Bonjour,

Merci pour l'intérêt que vous portez à mon problème.
Comme indiqué sur mon post de départ
"J’ai donc supprimé au niveau d’Images les médias d’origine (a) et (b) et les liens au niveau de l’événement.
J’ai associé les deux média un par un à l’événement concerné en fonction de mon modèle de nommage et vérifié que l’emplacement et le nom du fichier étaient corrects, ce qui était le cas ..."
J'utilise cette fonctionnalité de nommage depuis plusieurs mois et n'ai pas rencontré de problème jusqu'alors. J'ai déjà utilisé l'option d'un complément pour le nom d'un média.
Avant de poser ma question j'ai fait ces vérifications au niveau d'Images aves l'explorateur Windows, bien entendu je peux comme tout un chacun me tromper.
Bizarrement je découvre ce souci sur une généalogie de plus de 22 200 personnes et 20 000 médias.
Tout cela pour dire que jusqu'ici le système a bien réagi.
En pièces jointes les modèles de nommage que j'utilise et une photo de l'arborescence Images où le (1) a été rajouté enfin du nom de fichier pour l'union Tissier Raymond X Quertin Marie Josèphe.
Je confirme que lors de l'association de ces médias à plusieurs heures d'intervalle le (1) n'était pas présent sur la fenêtre d'association.
Ignorant comment fonctionne la tâche de fonds qui rafraichit le dossier Images je ne sais pas ce qui se passe ..
 
Membre
Bonjour,

Merci pour l'intérêt que vous portez à mon problème.
Comme indiqué sur mon post de départ
"J’ai donc supprimé au niveau d’Images les médias d’origine (a) et (b) et les liens au niveau de l’événement.
J’ai associé les deux média un par un à l’événement concerné en fonction de mon modèle de nommage et vérifié que l’emplacement et le nom du fichier étaient corrects, ce qui était le cas ..."
J'utilise cette fonctionnalité de nommage depuis plusieurs mois et n'ai pas rencontré de problème jusqu'alors. J'ai déjà utilisé l'option d'un complément pour le nom d'un média.
Avant de poser ma question j'ai fait ces vérifications au niveau d'Images aves l'explorateur Windows, bien entendu je peux comme tout un chacun me tromper.
Bizarrement je découvre ce souci sur une généalogie de plus de 22 200 personnes et 20 000 médias.
Tout cela pour dire que jusqu'ici le système a bien réagi.
En pièces jointes les modèles de nommage que j'utilise et une photo de l'arborescence Images où le (1) a été rajouté enfin du nom de fichier pour l'union Tissier Raymond X Quertin Marie Josèphe.
Je confirme que lors de l'association de ces médias à plusieurs heures d'intervalle le (1) n'était pas présent sur la fenêtre d'association.
Ignorant comment fonctionne la tâche de fonds qui rafraichit le dossier Images je ne sais pas ce qui se passe ..
 
Fichiers joints
  • Arborescence Images.jpeg
    Arborescence Images.jpeg
    135.2 KB · Affichages: 2
  • Modèle événement couple.jpeg
    Modèle événement couple.jpeg
    130.4 KB · Affichages: 2
  • Modèle événement personne.jpeg
    Modèle événement personne.jpeg
    127 KB · Affichages: 2
Membre expert
Modérateur
BétaTesteur Généatique
Oui, je m'intéresse à votre problème car lors des béta-tests de G2021 ces problèmes de (n) ont été longtemps difficile à résoudre. Je les crois résolus pour G2021 mais peut-être avec une restriction quand il y a un complément du nom. La bonne nouvelle c'est que même si il y a un (1) en trop, ça ne compromet pas l'association sans ambiguïté entre l'image et l'événement. G2022 gère bien cet aspect des compléments du nom : Ce complément est considéré comme faisant partie du nom et l'attribution d'un (1) en tient compte, ce dont je ne suis pas sûr à 100% avec G2021. Je vais regarder d'un peu plus près.
J'ajoute que G2022 permet , après coup, d'ajouter ou de modifier un complément du nom et par exemple une image "DUPOND_Jean Marcel_N_1785 (1).jpg" verra son (1) supprimé si j'ajoute un complément de nom.
Votre modèle de nommage est correct, même si pour les événements de la personne, la date complète serait préférable car le risque d'homonyme est plus grand que pour les événements de couple.
Je regarde G2021 pour ces compléments de noms.
EDIT: Ce que fait la tâche de fond n'est en effet pas toujours très clair, en partier le temps de réaction de cette tâche semble être très variable. Mais elle semble faire correctement son travail de mise à jour des noms de médias. Si on veut accélérer la mise à jour des noms, on peut faire "Utilitaires/Illustrations/Gestion des médias" et lancer le "Appliquer ces préférences" (tout en bas).
 
Dernière édition:
Membre expert
Modérateur
BétaTesteur Généatique
Je confirme qu'il y a un problème résiduel avec cette gestion des (1). Il se produit dans les conditions suivantes
- Une image d'un événement existe déjà
- A cet événement vous ajoutez une autre image ; si elle n'a pas de complément de nom elle aura un (1), c'est normal. Si vous ajoutez un complément, il n'y aura pas ce (1) Normal et très bien.
- Le problème arrive si avec un complément pour la seconde image, vous faites "Utilitaires/Illustrations/Gestion des médias" et "Appliquer ces préférences". On a alors les deux images qui prennent le (1), même celle qui a un complément. Il est probable que même sans déclencher ce "Appliquer ces préférences", la tâche de fond conduise au même résultat au bout d'un certain temps.
- G2022 n'a pas ce problème et même il corrige les noms qui sous G2021 auraient eu ce problème. Donc pour l'instant acceptez ces (1) en trop, il seront corrigés dans votre future version de Généatique :)
 
Membre
Je confirme qu'il y a un problème résiduel avec cette gestion des (1). Il se produit dans les conditions suivantes
- Une image d'un événement existe déjà
- A cet événement vous ajoutez une autre image ; si elle n'a pas de complément de nom elle aura un (1), c'est normal. Si vous ajoutez un complément, il n'y aura pas ce (1) Normal et très bien.
- Le problème arrive si avec un complément pour la seconde image, vous faites "Utilitaires/Illustrations/Gestion des médias" et "Appliquer ces préférences". On a alors les deux images qui prennent le (1), même celle qui a un complément. Il est probable que même sans déclencher ce "Appliquer ces préférences", la tâche de fond conduise au même résultat au bout d'un certain temps.
- G2022 n'a pas ce problème et même il corrige les noms qui sous G2021 auraient eu ce problème. Donc pour l'instant acceptez ces (1) en trop, il seront corrigés dans votre future version de Généatique :)
Merci pour votre réponse, j'ai mis ces quelques fiches sous "surveillance". Je vous confirme que le (1) en trop n'est pas "douloureux" et que je vais faire avec pour le moment.
Bonne journée
 
Membre
Merci pour votre réponse, j'ai mis ces quelques fiches sous "surveillance". Je vous confirme que le (1) en trop n'est pas "douloureux" et que je vais faire avec pour le moment.
Bonne journée
En complément de la discussion, je souhaite apporter les précisions suivantes, la gestion du nommage de fichiers avec un complément fonctionne correctement dans un cas de figure précis.
Pour un événement par exemple vous avez la mère et l'enfant qui décèdent le même jour et qui portent le même prénom. le modèle de nommage va ajouter un (1) à l'association du deuxième média alors que vous traitez deux personnes (deux fiches) différentes mais Généatique au niveau d'Images considère qu'il y a un doublon de média. L'application du [complément] permet de contourner ce souci.
D'autres exemples comme des cousins germains nés le même jour et portant le prénom du grand-père, seul l'ajout du [complément] permet de contourner ce cas de figure pour éviter le (1) sur le deuxième média.
Par contre la gestion du nommage n'est plus correcte dès qu'il y a plusieurs médias différents (copie, associatif ou autre) pour une même personne et pour un même événement. Généatique prend bien en compte le [complément] mais ajoute de manière insidieuse le (1) puisqu'il ne le montre pas au moment de l'association.
Je viens de vérifier l'ensemble de mes médias dans Images via l'explorateur Windows pour arriver à ce constat.
 

gratuit

Haut