• Bienvenue sur la nouvelle version du forum Guide de généalogie,

    Si vous avez du mal à vous connecter, faites une demande de réinitialisation de mot de passe : Réinitialiser mon mot de passe
  • Découvrez la nouvelle section du forum : Réalisations dans Généatique. Montrez et partagez vos créations d'arbres dans Généatique !
    Et participez au concours !

recherche par "attribut de date"

Membre actif
Je viens encore une fois faire appel aux lumières de Prédigny (ou d'autres).

Je voudrais produire la liste de tous mes sosas dont l'attribut de date est "ag".
Je pense que je peux passer par "Document / Liste sélective / Présélection et conditions". Mais ensuite, lorsqu'il s'agit de "définir la condition", je ne sais pas où trouver les attributs de date. J'ai tout regardé mais je ne vois pas de critère permettant de poser une condition sur la valeur donnée au paramètre "attribut de date".

(Si je fais "Rechercher / Recherche ou création d'une personne / Autre recherche", j'arrive sur la même fenêtre "Créer ou modifier une condition" et je ne trouve pas davantage les attributs de date.)

Merci de votre aide.
 
Membre actif
Bonjour,
Ce champ est, comme son nom l'indique, un attribut de date.
C'est à dire qu'il est lié aux dates de naissance, baptême, union, etc...

Il faut donc créer autant de condition que de champ date reliés par des OU :
naiss:acte = "ag" OU bapt:acte = "ag" OU union:acte = "ag" OU ...
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
Bergay":1wbev9ra a dit:
Je viens encore une fois faire appel aux lumières de Prédigny (ou d'autres)....
Ce sera avec plaisir mais quel est votre Généatique ?
Sous G2020 j'ai ce modèle qui devrait faire l'affaire ; il liste les personnes qui ont un événement BMS/NMD avec un acte=ag
 
Fichiers joints
  • liste-sosa-NBMDS-avec-conjoint.zip
    2.3 KB · Affichages: 61
Membre actif
Merci Prédigny mais ça n'a pas fontionné.

J'ai effectivement Généatique 2020.

J'ai dézippé le fichier et obtenu un fichier LSM que j'ai mis dans le dossier D:\Généatique\Mes descriptifs 2020\Mes Modèles

Ensuite je suis allé dans ma généalogie, me suis fixé sur le De Cujus et ai cliqué sur Documents / liste sélective.
Ensuite j'ai cliqué sur "Ouvrir" et j'ai choisi le fichier LSM que vous m'avez envoyé.
Ensuite j'ai cliqué sur "Suivant" puis "Réaliser la liste".
j'obtiens 27 pages blanches ! Gasp !

Dans la rubrique "Conditions", je ne vois aucune condition, donc ça ne peut pas marcher pour filtrer par les attributs de dates. Par contre je me demande pourquoi j'ai des pages blanches, je devrais avoir la liste de toute ma généalogie.
 
Membre actif
Philippe Gauthier":3ictnmot a dit:
Bonjour,
Ce champ est, comme son nom l'indique, un attribut de date.
C'est à dire qu'il est lié aux dates de naissance, baptême, union, etc...

Il faut donc créer autant de condition que de champ date reliés par des OU :
naiss:acte = "ag" OU bapt:acte = "ag" OU union:acte = "ag" OU ...

J'ai eu du mal à trouver la solution ! Mais j'ai fini par y arriver.
Voici la procédure pas à pas :

Il faut cliquer sur Documents / Liste sélective
Choisir un modèle dans toutes les listes disponibles à gauche, puis cliquer en bas à gauche sur "Suivant".
Vérifier le choix de la personne et le nombre de générations.
Puis cliquer sur "Définir la condition".
Là, en haut à gauche, il ne faut pas choisir "personne" mais 'événement'.
Dans le cadre au dessous, cliquer sur 'Données' puis 'Acte'.
Faire entrer ce paramètre dans le cadre de droite en cliquant sur l'icône tournevis.
On obtient ce paramètre : even:acte
Cliquer sur égal puis entrer 'ag' sans guillemets.
Cliquer sur OK
Cliquer sur "Réaliser la liste"
Ouf !
Voici la liste qui apparaît avec seulement les personnes dont la date porte l'attribut "ag".
 
Membre expert
Modérateur
BétaTesteur Généatique
Ambassadeur Généatique
J'ai téléchargé le modèle que j'avais mis plus haut et chez moi il fonctionne très bien.
La condition est ici (en "Mode avancé" :

cond.jpg
En fait, je crois que votre erreur c'est de cliquer sur Ouvrir ; j'ai fait la manœuvre et en effet, en faisant cela ça ne marche pas car le modèle était déjà dans la liste et en faisant cela, il y est deux fois et le programme se sait plus les gérer. Donc supprimez un des deux modèles et ça devrait mieux marcher.
 
Membre actif
@ Prédigny

Oui effectivement.J'ai supprimé le modèle et l'ai collé à nouveau dans D:\Généatique\Mes descriptifs 2020\Mes Modèles
Et, une fois dans la liste sélective, j'ai cliqué sur le modèle sans passer par "ouvrir".
Et j'ai la liste bien formatée.

Merci !
 

gratuit

Haut